SONOS speakers stop working after new IP


(Sean Vreeland) #1

So I have several SONOS speakers that work great thru the SONOS connect app…UNTIL they get a new IP from the router…does anyone else have this issue where if you are to reboot your router and then go BACK into the SONOS connect app, it find NEW speakers that are actually just a duplicate of the previously connected speakers?

REALLY frustrating.


(Greg) #2

Yes, setting mac address reservations for the sonos (sonoi?) fixed this for me


(Sean Vreeland) #3

@greg LOL… SONOI…ha

Umm, okay, I have advanced knowlege of IP routing…I’m using a Netgear R7000 on WRT. Take a look at the screen shot… Is this where I would enter that info? If so, what would I put for the lease time? I tried to leave it blank thinking it wouldn’t enforce a lease, but I have to put in a value.

Thanks


(Greg) #4

I’m not familiar with that router, but yes that looks like a good place to try.


(Ule) #5

Hi , sonnos connec app , search every few minutes for ip changes to update the ip or port if the speaker was changed.

You must to wait to connect to seach , find and update the data.

The app save the uuid from each sonos and search the ip, you can not duplicate the sonos speakers , unless you have installed several sonos connect app, you must have just 1 sonos connect app.

I suggest you try to seach your sonos in yor network with some external app like ios browse upnp, to check if your roter have upnp service turned on.

If you can find the speakers in browse upnp, then your smarthing must to find the sonos.


(Chuckles) #6

DD-WRT, OpenWRT, … ?

I’m not sure what’s going on with it asking for a “Client Lease Time” on a reservation. Are you running a stable release or are you seeing a bug in a development build? (The sloppy misalignment of the input boxes in your screenshot, together with the fact it is asking for this information in the first place, makes me ask)

The Client Lease Time option is normally either a server wide or a scope wide option, but in any event it has no meaning for Static Leases / DHCP Reservations - the whole point is that they’re “static” - they don’t have a time limit.


(Morgan) #7

Yes, this is a known issue. Just set the Sonos to have static IPs or use Mac Addresses so they are always the same IP and bam solved.

Sonos text2speech has been super flaky recently though.