Sonos keeps disconnecting! - help!


#1

I keep setting up my Sonos speakers with ST. Then after awhile, ST can’t control them even though it looks like they are connected. I usually have to remove each speaker and re-connect to get them to work, and they it starts all over again.

Can anyone help with this problem??? Why does this keep happening? IfST can connect with Sonos to start with, why does it keep disconnecting?

Help!

Thanks.


(Greg) #2

Have you set up a MAC address reservation for the speakers? I had the same problem you described, but never again after setting up reservations.


#3

I have absolutely no idea how to go about doing that! If you could give me the step by step instructions to do it (written for someone who needs their hands held at every step!), it would be greatly appreciated.

Thanks!


(Greg) #4

What router do you have?


#5

It’s a router provided by Time Warner cable - other than that I don’t know


(Greg) #6

It should still have a make and model.

If you just log into your router you will probably find a settings page where you can make the reservations. You will just type in the MAC address of each speaker. Then reboot your router. Then reconnect each speaker and you should be good.


#7

I do know how to log onto the router. But I’m confused as to what I need to do. Aren’t the addresses dynamic and set by the router? Are you saying I need to designate/set an address for each speaker in the router? And then when I do, what do I do on the ST side of things?

I really appreciate you taking the time to help me with this. Thanks again.


#8

I’m looking online - is this mac address filtering? And I’m a bit confused, it looks like each speaker has its own MAC address - it isn’t changeable is it? So what am I then doing to make a “reservation” as you are suggesting?


(Stuart Buchanan) #9

@logar it’s nothing to do with MAC address filtering that’s for restricting acces to you wifi by MAC address. Setting echo setteing in routers is usually under the LAN settings.

The reason he is suggesting reservations is because the router assigns IP’s dynamically and your sonos is given an IP and then you discover the sonos on that IP in smartthings so when this IP changes Smarthings will still try to speak to the device on its old IP until you do a rediscovery on its new IP.

It’s best to set static DHCP reservations for your whole internet of things otherwise you will hit issues like this. I’m not sure any of us can really assist with assisting on a specific model of router unless one of the members here has the same model. It will be worth reaching out to your ISP’s support as they should be able to assist quickly failing that see if you can source the manual for your specific router and post it here and then the community will be able to assist.


(Adrian) #10

Thanks for this, mine was doing the same thing. I’ll set a reservation so it keeps the same IP address. I thought it was a bug or just didn’t work.