Sonos device not found and automation issues

I’m currently experiencing 2 issues.

  1. I have an automation that I removed a device from and the device still runs. I next tried deleting the automation, obviously without the device, and it still runs. I turned the automation off and the device still runs. Suggestions?

  2. Sonos stopped being controlled by SmartThings. I tried deleting and re-adding Sonos to the SmartThings app. SmartThings does not find any of the speakers. Two of them are within 10ft of the hub.I restarted the hub, no difference. However, ActionTiles still controls the speakers.


As far as Sonos is concerned there are currently issues that have been on-going for a while now.

ST are aware and working on a fix. Full discussion here:

I’m having similar issues over the last few days. I have several One and One SLs randomly going ‘offline’. Deleting them and rescanning fixed the issue for a day or two but then offline again. All are still accessible as media renderers under the Personal Devices section.

what device did you remove? does History show any Routine as the culprit? check all your routines, smart lighting and Rules API? or a scene that may contain that device and is being called from a Routine? and have to ask… do you use Alexa and is Hunches enabled? If yes, check if it created a Routine in Alexa.

The strange thing is Actiontiles is a dashboard for SmartThings (in my usage) and it’s controlling devices that are no longer contained in my SmartThings as I deleted them.

Thank you. I had the light in another Manually Run Routine and deleted it from there. It didn’t come on this morning, so maybe that was the issue. It could be that in removing ‘automations’ and making everything ‘routines’, that caused an issue.

Unfortunately I deleted the speakers and they will not re-add.