Sonos control app, play/pause toggle does not pause

I have a Sonos Play 5 and connected a button to the Sonos Control app. I choose the Play/Pause action and it will start to play but the pause will never happen. If I pause the Sonos on the physical speaker itself, the next button press will un-pause but pressing again does nothing.

Anyone else seeing this? Known issue?

Working for me. Play1. Are you using the official app from ST?

Yup, it is the one listed under sounds/speakers. Tried restarting the hub but still not working as expected.

Sonos integration has always been garbage. It has never worked right for me in two years, even more so if you are trying to control grouped players.

You could try reinstalling the Connect app, but in general, Sonos integration is one of those ST doesn’t care / has horrible QA issues.

Thank you for the heads up. That is really too bad. State of the Sonos is incorrect and using smartthings to control sonos seems to fail.

My last resort is to use IFTTT to control it through dropbox and SoCo but now I have issues with pyinotify that monitors the dropbox folder… Gah!

Ok, just avoided ST altogether and used an Amazon Dash button and a variation of my python script to control sonos through SoCo upon dash button press.

Works like a charm and even if internet connection happen to be broken.

1 Like