[Solved] Am I the only one with a Sonos Playbar problem?


(Jesse S) #1

Hi All,

I noticed that since Sonos released the 7.0 version of their app my Playbar has been acting a bit odd. Before 7.0, I could pause, play, skip tracks, and adjust volume with ST’s integration. Now, my play:3’s and play:5’s work fine, but the playbar only responds to volume adjustments. If anyone here has a playbar at home, would you mind:

  1. Play some audio from Pandora or whatever service you use on the playbar
  2. See if the ST app recognizes what’s being played (there’s a little scrolling marquee under the pause/play button in the ST app)
  3. See if any commands other than volume work

I’m trying to figure out the issue on this end, but haven’t been able to successfully diagnose things yet. It would be super helpful to know if I’m the only one experiencing the problem or if other people were affected by the update.

Thanks All!


(Brett) #2

I just tested this on my Living room Sonos group and it worked fine, which includes a Playbar, Sub, and 2 Play:3’s. I’m not sure if it matters that its setup as surround sound or not though.


(Jesse S) #3

Did everything go ok?


(Michael) #4

I have yet to get the Sonos and ST integration to show any value. Not sure the perk of using ST to make these changes vs the native Sonos app considering the control limitations?

I am waiting for dubbedout to repsond on his results as I also have my Playbar, Sub, and Play:3s in a surround setup.


(Brett) #5

Sorry, yes everything worked as expected.


(Michael) #6

Just confirmed that my Playbar and a stand alone Play1 work fine via the ST app. I can play, pause, adj volume, and skip on both. The song info also appears. I confirmed the same behavior using a local queue as well as a Pandora station. All tests pass.

Sonos Version: 7.2
Device: iPhone6
ST App: 2.3.0

TestA:

  • Playbar
  • Sub
  • Play1 surrounds

TestB:

  • Play1 stand alone

(Jesse S) #7

@michael2 @dubbedout

Thank you both for checking and confirming that this is a local problem. I’m continuing to investigate and stumbled on some interesting things… For one, the ST API sees the playbar as “online”, but hasn’t received an updated status since March 3rd (almost a month ago)…

I also see that when I launch the marketplace > add things > labs > sonos device discovery process that the ST API kicks out log line items that recognize the playbar on the network, even though nothing is listed in the app itself.

Follow-up question for you two – if you go into the marketplace > add things> labs > sonos discovery, do your already-connected devices show up?

Thanks again!


(Brett) #8

I don’t even see Sonos under Labs anymore. I just recently added a new Play:5 and it showed up under add a Thing. What device type does it show for your Playbar in your IDE?


(Michael) #9

As dubbedout stated…the current version of the ST app should show the Sonos to add via the “Add A Thing” option, not the Labs option. This is how I just added mine to test for you. I had removed my Sonos from ST months ago since I hadn’t found it useful yet.

And from what I just tested, I do not see my already connected/discovered Sonos in the Add a Thing list.


(Jesse S) #10

@dubbedout Yeah, the Sonos connect is all the way at the bottom of the Marketplace > things section now instead of the Marketplace > Smart Apps… You have to scroll to find it. To your question about the device time, I just confirmed it’s listed as “LAN Sonos Player,” which is what should be expected.

@michael2 Yes, the smart app in labs disappeared, but a device-specific option showed up in the Marketplace > things section… I think this might be a faster way to find a specific device, so in this case it seemed like a good thing to do. Thank you for checking your system and confirming that you could add it… I’m reluctant to remove my playbar because it’s tied to a bunch of apps and I don’t want to have to deal with the headache of reinstalling everything. That said, it might be worth doing…

Oh, and in terms of how ST is useful for Sonos… The #1 most useful thing I’ve found so far is controlling the volume by voice with Alexa. It’s through a custom app I put together last summer, but there’s other approaches other people have come up with since then:

Anyway, thank you both for your input as I debug!


(Jesse S) #11

Solved! Thanks to some back-and-forth with Bill at ST tech support, we were able to get the Sonos-ST integration working with full functionality!

Here’s the two clues:

  1. In the ST graph.api, the Sonos speaker was listed with the right MAC address, but the wrong IP address. Unfortunately, this wasn’t obvious at first because the IP is listed in hex. In my case, I saw the speaker was recorded by ST as 192.168.1.16, which displays as C0A80110, but the actual IP according to the router was 192.168.1.18, which should display as C0A80112. Again, not an obvious clue, but it was big.

  2. The second clue was in the Super LAN Connect log files in the graph.api… Turns out SLC saw one MAC address (the speaker), but was reading two different IP address. For example, I’d see:

…mac:B8E93770EB91, networkAddress:C0A80112, …

and then in the next line:

…mac:B8E93770EB91, networkAddress:C0A80110, …

Notice that these two addresses have both the right and wrong IP. Somehow this allowed me to adjust volume via the ST app, but not pause/play/skip.

Anyway, Bill was able to change the IP of the device on his end to the correct value. Once he had done so, full functionality was restored!

Now, time to make dinner and “Alexa, turn on the living room Sonos!”