SOLVED: New Alexa not discovering any ST Devices

Got a brand spanking new Alexa Echo (& Echo dot. More on that below) and the initial setup was pretty painless. I added the Smartthings skills and created a few groups which included ST devices (among others). Alexa controlled the groups perfectly. Then my problems began

I noticed that many of the discovered devices were duplicated (i.e. Wemo and Hue devices) and not being aware that I could have filtered out the duplicates via the ST smartapp “Amazon Alexa” I disabled the Smartthings Skill. That did nothing. I then decided to reset the Echo by unlinking it from one amazon account and linking it to another account and went though the entire Echo setup procedures and re-enabling the required Skills… All my devices (& skills) were back to normal EXCEPT ANYTHING FROM SMARTTHINGS. I even performed a factory reset of the echo and the results were the same. No ST devices discovered.

I shutdown the echo and unpacked the new Echo dot… I went through the setup, added the required skills and once again, everything was fine except ST devices.

I have rebooted every that could be rebooted, removed and re-installed every required app but have made no progress. I am at a total loss.Why is this so difficult? The Wemo and Hue devices were discovered immediately and have worked perfectly since.

Login to and click forget all devices in the settings section. Then make sure the right device list is set in your ST Alexa connect SmartApp. Then ask Alexa to discover devices.

1 Like

Thanks for the quick response. Unfortunately, the results were the same as above. All but my ST devices are (re)discovered.

1 Like

I am having the same problem. I began installing ST devices to my home a year ago. I now have 45 different devices installed, and I use 2 different Amazon Dots to control devices by voice. All devices function properly using the ST app. The 40 devices that have been in my home for months are all functioning properly through the Alxa app. The 5 newest devices are undiscoverable by the Alexa devices, and no matter what I try, Alexa tells me that no new devices are discovered.

I called Amazon to troubleshoot, and all I get is some drone who wants to talk me through a script of things that I have already tried. The one thing that they want me to do I am not willing to try, is they have asked me to uninstall the skill and reinstall it. I do not want to do that, because if that doesn’t fix the problem, the 40 devices that I currently have control over may also wind up being undiscoverable, and then I will have no control over my house, except through the ST app. I tried telling Alexa to forget one device to see what would happen. It didn’t discover the device again.

When I pointed this out to the support guy, he said that he couldn’t forward me to more advanced tech support unless I tried this step, and he said he guarantees that it will work. I then asked him if he guarantees it, would this mean that Amazon would refund my money for the dots. He said no, at that point they would send it up the line, and I would expect an answer within 7-10 days.

For this reason, I may be switching to another device, like perhaps the Google devices. Amazon tech support is awful.

Yeah, I uninstalled and re-installed the skill numerous times. doesn’t do anything. The thing is… If I were the Amazon support geek trying to solve my problem it would go something like:
Geek: are hue devices discoverable?
me: yes
geek: are wemo devices discoverable?
me: yes
geek: are harmony devices discoverable?
me: yes
Geek: are ST devices discoverable?
me: No
Geek: talk to ST support. Have a nice day.


I submitted a ticket with ST support and got back this response

Jordan (SmartThings)

Dec 22, 8:19 AM MST

Hi there,

Thank you for contacting SmartThings! Sorry for all the trouble with discovering SmartThings devices through the Alexa app. I’m happy to help!

Amazon Alexa devices can only be connected to one Location at a time. If Amazon will not authorize the SmartThings account, it may be that the Amazon account is currently connected to a SmartThings account. Can you confirm Amazon (Connect) SmartApp is not currently installed on the account?

I look forward to your reply back.

Best wishes,
Tier II Support

I have 2 hubs and at some point (of frustration) during initial setup I must have tried to setup both hubs. Once I removed the ST app Amazon Alexa from the one hub (v1 hub) all the devices from my main ST hub were discoverable.

Very happy. Hope this thread may help others with the same or simialr problems


Thank you… Once I got the st devices discovered this worked perfectly

Please forgive my ignorance, can you spell out in a little more detail what your fix was?


Sorry but that happened over a year and a half ago. I really dont recall what the issue was and how to fix it.

1 Like

The OP explains above:

Once I removed the ST app Amazon Alexa from the one hub (v1 hub) all the devices from my main ST hub were discoverable.

There is no fix if you are trying to connect two SmartThings hubs to Alexa, even if it is two different Amazon accounts. ( such as if you have a main home and a relative’s home both as locations on one smartthings account, you each have an Alexa account, and you try to add Alexa at each location.)

Basically even though smartthings allows you to have two locations on one account, this will confuse echo.

There’s an official support statement that says they are working on this feature, but don’t get excited about that: it’s been the same statement for three years now. :disappointed_relieved:

Can I control multiple SmartThings Locations with Alexa?
No, not at this time. But we are working on an update that will allow multiple Amazon Alexa devices on separate Amazon accounts to control separate SmartThings Locations.

So basically each hub has to have its own smartthings account and its own echo account if you want Alexa control to work with SmartThings, only a one to one correspondence is allowed at this time.

1 Like

Thanks for the help so much. I have been running smarthings hub and alexas at home(primary) and work for over a year. I have ecobee thermostats, phillips hues bulbs, and a all my switches are GE switches. I have had no issues for over a year. The devices that ran through the smartthings app i could control by alexa at my home/primary location, but i could not voice control at the office. I could control my home devices from the office or home.

Earlier this week I had an electrician come and install recessed lighting and a few more ge switches at my home. After power was restored, my alexa would not discover the new devices and all my switches/locks connected via smartthings showed offline. Smarthings app still controls everything just fine.

Troubleshoot steps taken:
1.recycle power
2.on alexa app, disabled smarthings skills, re enabled skills, then tried switching locations, did not work, disabled skills and went back to primary, didnt work.
3. logged onto alexa online and did forget all devices, when i did this and then discovered all the smarthings went from online to gone, they do not show anymore.
4. deleted any duplicate devices
5. open settings on my phone, Apps, Application manager, Amazon Alexa, storage then clear data, force stop Alexa and re-sign in; disable ST skills then enable ST skills

I am sure I have done more, thats all i can think of at the moment. I just dont know what to do to get it back just like it was. Thanks so much for taking the time to try to help me, I’m not very techy, at all, lol.

Appreciate you all,

The truth is, you just got lucky the first time. It’s random as to which devices echo will be able to see when you have more than one location on the same account. There may not be any way to get back to where you had it before because it’s not a currently supported configuration. :disappointed_relieved:

The only other thing you could try, but it would be a huge pain and I don’t know that it would fix anything, would be to completely remove the office location and all of its devices from both SmartThings and Echo, Then set up echo from scratch at the home location and make sure everything is working, and then add the office hub back to SmartThings and don’t make any effort to join it to Echo.

But that might not work. And the first time somebody said “echo, discover new devices” it might all break again.

I wish I had a better answer for you, but, like I said, at the present time it’s just not a supported configuration. There are multiple threads in the forum with people reporting the issue, but nobody has found a permanent workaround solution for it.

1 Like

Thanks so much for your time, I am grateful!

Hi All,
I was stuck here as well, but solved my problem. After having my own home (hub) setup with Alexa, I setup a hub for my parents, and enabled Alexa skill on their Alexa account.

Quick Recap:
One Smartthings account attempting to share on 2 different Alexa accounts. End result was that I could initially control all devices, but any new devices I added to my Hub would not be discovered. In fact, even if I disabled the Alexa skill, and forgot all devices, when I tried to discover again, it would only discover devices at my parents house.

I had to disable the Smartthings Skill in both my Alexa account, and my parents Alexa account. This was the only way to get it working on my house. After that I “forgot all devices”, enabled the skill again, and discovered all devices. This brought my devices back into Alexa.

Thanks everyone for this thread, after understanding the problem, I realized the issue. Hope this helps someone else trying to troubleshoot.

Hi, everyone who ran in to this problem, I manged to resolve the issue. I have V2 hub , two Alexa dots , two Fire 7, Google home and Alexa reverb. Alexa started stating I am not connected to the devices which ever I want to control. I have been using this set up for over two years. Yesterday I had to do a Z-wave repair session after removing a Schlage lock which went off line due to battery power. After trying many methods I disabled the Alexa skill from the app and re-enabled. All devices were discovered.