[SOLVED] Aeotech MultiSensor 6 Edge Driver Issue


I’m continuing my journey towards edge, and have today just decided to try the Samsung Beta channel to move across an Aeon Tech Multisensor 6.

I have installed the zwave sensor driver on the hub. Commented out the fingerprint on the groovy DTH, removed the existing device from my zwave network.

I then reset the sensor, and started the scan for my device. It was promptly found by the hub and installed with the edge driver.

However, it constantly reports motion as being detected, even when there is none. I can confirm this from the logcat logs where the value notification_status=“ON” is constantly shown when other events are reported like luminance.

The device was working fine before with the all DTH.

Any suggested on what steps I could take next?


So I have done some further investigation.

I can see the events being reported in logcat. I was mistaken above, the notification status was a red herring it seems to look at the ‘event’ attribute. “STATE_IDLE” when movement is not captured and “MOTION_DETECTION” when the sensor picks up movement.

The events come through in a timely manner to the hub, however the state of the device is not updated in the Smartthings app.

However, if I press the Action button once on the back of the device, the state is transmitted again and updated in the app in realtime. 1 button press is supposed to be the exclude command according to the manual, so why this forces the app to refresh is unknown. The message in the logcat will show as TRANSMIT_COMPLETE_OK.

If you try and force a refresh of the device in the Smartthings app, you get a TRANSMIT_COMPLETE_NO_ACK message in the logcat output

One option is to try the Aeotec driver for this device.

Even if you decide to go with the Aeotec driver, could you post the logs from the ST beta driver when you’re triggering motion? I’m wondering if any other z-wave command comes in along with the Notification report. The code for that driver shows Notification reports are ignored unless they’re related to whether or not the device is plugged in. If it really is only sending a Notification report that’s being ignored, then ST needs to take another look at the driver.

Sleepy z-wave devices like battery powered sensors go to sleep for long periods of time, then wake up briefly to allow for hub communication. What you’re describing is expected behavior if the device is asleep.

Most sleepy devices have a way to manually wake them up, and this appears to be yours. It could also double as the exclude button, but it will only remove itself.from your hub if the hub is in exclude mode.

1 Like

Thank you @philh30.

I did not realise there was an official driver from Aeotech. Installed that and it now works a treat.

Before your reply I was amending the default driver from Samsung which has this devices as a profile with additional parameters over a stock sensor, and was adding in certain reporting parameters to the driver based on the Aeotech parameter reference re wake up that are not included by default etc. No need to continue down that road anymore


This might help explain. It appears you were trying to update the parameter values on a sleepy device, and they were queueing for later processing, which is normal. Pressing the action button wakes up the device again. See the community FAQ:

FAQ: Configuration Changes for Battery-powered Zwave Devices

It does indeed @JDRoberts.

I had not made changes to the driver at that point. It was like the device was sending stuff to the hub as you could see it logged, it would just never update in the app unless you manually woke the device with the button.

All good info for the future. Hopefully this thread will sign post a solution for someone else once the migration takes place with this device, as even though it has the fingerprint to work in the Samsung drivers, its obviously not complete which I think will raise the question for others.

1 Like

There’s a pull request open that looks like it will specifically address this issue in the ST driver, assuming your device is sending a Basic:Set command when the motion sensor is triggered.


Hopefully that will fix the issue for people on migration day without having to go down the aeotec route. (Although I prefer a manufacturers driver myself)