SmartThings Community

SmartTiles: Video Camera Compatibility

Ray, it doesn’t work.

My paste screwed up on the last post. Try open with a browser first. I remember playing with yawcam quite a while ago. Might want to google it.

http://ip:port/video.mjpeg&-usr=USERNAME&-pwd=PASSWORD

Still doesn’t work. I’d been searching in yawcam forum but seems no one is usng it for smarttile. I can open it thru browser with ip:port and yawcam box open and ask for usr&pwd. It should suppose to be like that when you enter in smarttile url or in smarttile is different thing.

@protocol I don’t want to flood this post so I PM you a link page. Let us know which one will work to help the next person.

Anybody having issues access their FOSCAM cams lately. I have not made any changes to anything but it I can not view my cams via the DDNS xxxx.myfoscam.org:xxxx this week. They had been working fine with the dashboard and any web browser before. I’ve tried their support but have not gotten any response from them.

I’ve been trying to get my foscam 9803p v2 to stream via to mjpeg (sub stream) but can’t get it to work. That aside, if I do this, it makes the mainstream mjpeg also… and I lose the quality. It’s 720 res and i’m pretty sure mjpeg doesn’t support that res or does it (for main stream)?

RTSP Would be amazing and yes you do need a plugin i.e embed it in the player so it should be possible. http://stackoverflow.com/questions/2245040/how-can-i-display-an-rtsp-video-stream-in-a-web-page

1 Like

Here is a site that is helpful in determining the direct video URL for ip cams. http://www.ispyconnect.com/sources.aspx

Did anyone figure out how to correctly add a DB Power generic IP cam? I got the still working, but the live stream is eluding me and I have gone over the ISpy site for help.

I’m trying to get a FOSCAM FI9826P working and I’ve tried these various methods with no success. Ideas?

http://(using my internal IP):88/index.htm/videostream.cgi?user=xxxx&pwd=xxxx

http://(using my internal IP):88/videostream.cgi?user=xxxx&pwd=xxxx&resolution=32&rate=0

http://(using my internal IP):88/videostream.asf?user=xxxx&pwd=xxxx&resolution=64&rate=0

This and port forwarding.
http://(using my external IP):/videostream.cgi?user=xxxx&pwd=xxxx&resolution=32&rate=0

I’ve also looked at http://www.ispyconnect.com/sources.aspx and that’s where I was able to get some of these urls listed above.

Is the 9826 one of the H.264 cameras? If it is, did you set the one of the streams to MJPEG?
http://ip_address:port/cgi-bin/CGIProxy.fcgi?usr=admin&pwd=xxx&cmd=setSubStreamFormat&format=1

Then use the substream URL to get the feed…
http://ip_address:port/cgi-bin/CGIStream.cgi?cmd=GetMJStream&usr=admin&pwd=xxx

Take note of the difference in the cgi commands.

I’ve been trying to make this work on a 9821 but having no luck. Maybe yours will work.

@eibyer I been using the Foscam 9821 for a while and don’t have a problem with the code that you use. Are you setting the MJpeg for each web browser you are using? I also updating to the latest firmware for the camera.

@llcanada thanks for the confirmation that it works. What firmware version do you have on yours? I’ve been using IE to set the command and got the “0” confirmation that the stream was set. If I try to open the URL in IE via local network, IE prompts me to Save or Download the stream. Really odd. I tested the URL with VLC and it works.

I have the FI9826P and the FI9828P. Both of these are the new H.264 cameras.

This worked for my FI9826P camera.This did not work on my FI9828P camera.
http://ip_address:port/cgi-bin/CGIStream.cgi?cmd=GetMJStream&usr=admin&pwd=xxx

When you say MJPEG, I don’t get that option. I show 4 options under SubStream\Stream Type:

  1. HD Mode
  2. Equilibrium Mode
  3. Smooth Mode
  4. User-defined
    ----- this changes the resolution option to 720, VGA, QVGA

System Firmware Version = 1.4.1.10
Application Firmware Version = 2.11.1.119
Plug-In Version = 3.1.0.9

Still trying to figure out my FI9828P camera.

Thoughts?

@llcanada I loaded the URL in Chrome and Firefox and it worked! I must have been tooling around with this for a while that I forget which ones I have tried and which ones I haven’t.

I’m not sure if the FI9828P takes the same command to change one of the streams to mjpeg.

@eibyer I using Firefox and it works. I also try on the Internet Explorer and have no luck since it upgraded to 11. I will try to play around with IE and see if I can get it to work. Thanks for the update.

Can anyone suggest me a good cheap camera that is compatible with SmartTiles and has NAS storage or Local Storage?? :smile:

Hey guys, I can get a working URL for Dropcam, but the video tile is always blank on SmartTiles. I followed the directions perfectly, but I’m getting nowhere! Any thoughts?

Have you tried Chrome?

I heard that Firefox just dropped support for certain type of video streams. I don’t remember the specifics…

Anyone experiencing losing the video stream in Chrome from a Foscam camera? If I use Firefox it’s nice and consistently there, I just don’t like the way Firefox does the full-screen mode.

1 Like