SmartTiles: Video Camera Compatibility

dashboard
smarttiles.click
smarttiles
cameras
project_cameras

(Joaquin) #363

So, anyone solved the NestCam - Smarttiles integration?
Couldn’t find any around.
Would be great to have a working solution.


(stephen) #364

Can someone please help me integrate my samsung smart cam with smart tiles i read a way on how to convert with vlc but i do NOT understand and someone provide a step by step process how to stream through my vlc converter to smart tiles?!!! I’m using a MAC


#365

anyone know how to get the stream from SecuritySpy mac software into SmartTiles? or can suggest any other Mac camera software that can be used with the Samsung Outdoor Camera SNH-E6440BN. I have put the address from SecuritySpy into Generic MJPEG video streams as http://ipaddress:port/live?cameraNum=2&viewMethod=0&imageSize=scale0.25&windowWidth=1619&57384 this url works in a browser but I just get a grey tile in SmartTiles

i did have the http://admin:password@ipaddress/cgi-bin=video.cgi?msubmenu=mjpg working in a browser but now I get refused to connect error from the camera even though I know it’s working at that ip address. Anyone got SNH-E6440BN working with the tiles if so how you doing it? Thanks


#366

I am 99% there doing this via VLC… How do I figure out what my Samsung HD Pro’s unique port number is?

Thanks!


#367

I am with you; let me know if you find a way to get this figured out…


#368

I’m not sure what you mean by “unique port number”. The RTSP stream uses the standard RTSP port 554.


#369

Thanks for the reply @luma ; I am a bit of a noob at this, but am learning a lot… I was originally thinking that each IP camera had a unique port # tied to it. I first tried using port # 8000 like you did, but no dice. I was then using the “netstat -a” command to try to find a matching port number and swapping that into the command you shared. Based on your reply, should I try 554 where you put 8000 in your vlc command line? As of right now, I can get the command code to fire open VLC no problem, i enter my credentials and it then stream beautifully, its just the http page shows as unreachable for me…this lead me to believe port # issue. Thanks!

My IP: 192.168.1.XXX
HD PRO IP:192.168.1.YYY
PORT: 554

Here is how I am entering the command:

vlc.exe -I dummy --play-and-exit
rtsp://admin:password@192.168.1.YYY/profile3/media.smp
–sout=#transcode{acodec=none,vcodec=mjpg,vb=512,width=480,height=320}:standard{access=http{mime=multipart/x-mixed-replace;boundary=–7b3cc56e5f51db803f790dad720ed50a},mux=mpjpeg,dst=192.168.1.XXX:554/mjpeg.jpg}

Then i am checking for it to be available at URL:
http://192.168.1.XXX:554/mjpeg.jpg

Thanks!


#370

OK I think I see what you’re doing here. 554 is the port on the camera, which is the same on every RTSP camera and you don’t need to enter it in the command. What you’re looking at is the port on your PC which you can set to any value so long as something else on your PC isn’t already using it. So ignore 554 and use whatever you have free. In the example line I provided:

vlc.exe -I dummy --play-and-exit rtsp://admin:password@192.168.1.200/profile3/media.smp --sout=#transcode{acodec=none,vcodec=mjpg,vb=512,width=480,height=320}:standard{access=http{mime=multipart/x-mixed-replace;boundary=--7b3cc56e5f51db803f790dad720ed50a},mux=mpjpeg,dst=192.168.1.100:8000/mjpeg.jpg}

The last part where it says “dst=192.168.1.100:8000/mjpeg.jpg” tells VLC what port and path on your computer it should use to accept incoming connections. So that’s not your camera, that’s your computer’s IP and any available port you choose. Once this is running, you can point a browser (or SmartTiles) at http://192.168.1.100:8000/mjpeg.jpg to view the stream. So once again, that IP should be your PC’s IP, and the port is any available port on your PC. If for whatever reason 8000 doesn’t work, try 8001. Or 8002, etc.


(dhsemp) #371

Any chance there’s SmartTiles support for RTSP? Would love to connect my Ubiquiti ip cameras to SmartTiles. Thanks, Derek


(Darryl) #372

The problem is not SmartTiles, it is your web browser. If the web browser does not have a plugin for RTSP, it won’t work.


(Larry) #373

its not just rtsps the Samsung cameras use digest authentication which is not going to work with smarttiles


#374

That’s why I setup VLC to transcode!


#375

Ok; gotcha. I have tried 8000-80010 and am getting two below errors:

  1. access_output_http access out: Consider passing --http-host=IP on the command line instead.

  2. live555 demux error: Failed to connect with rtsp://admin:password@192.168.1.YYY/profile3/media.smp (with my info added of course)

Thanks!


#376

If you open VLC to show the normal GUI, then press Ctrl+N to bring up the Network stream, and enter rtsp://admin:password@192.168.1.YYY/profile3/media.smp does it play your camera video?


#377

Yep, an rtsp authentication window pops up that prompts me to enter a user name and password. I put in admin for user name and my cameras password and it then streams with no issues.


#378

Would you feel comfortable PMing me the command line along with the resulting console text? I’d be interested in the original IPs, maybe editing out the password.


#379

Sure; no problem. Whats the best way to PM you?


#380

For anyone following the thread, the issue was discovered to be some confusion about which password to use. The camera password is set in the mobile app, but it is probably different from the mobile app logon. Use the camera password, not the mobile app password, and things should work from there.


#381

@luma Indeed; my
feed has been working great in smarttiles all day!


#382

Hey @luma, have you experienced any issues with either the Smart things hub or Samsung’s software rebooting your HD Pro cams? I am seeing my cams going offline or getting rebooted almost daily for some unknown reason. When the cam goes offline/reboots, it kills my VLC stream. :frowning: Thanks!