SmartTiles Dashboard 5.4.2 - July 13 (www.SmartTiles.click)

I have a similar problem with the Dual Relay switches I have installed from MonoPrice. Using a custom device I found here I end up with a tile that says “Switch one” on my Smart things dashboard, I can toggle this and turn off the selected switch or if I want individual control I have to go into the configuration and then I can individual toggle them. In the dashboard it doesn’t get their correct states and I cannot turn them one or off at all. I am looking to figure out a better way to manage these in the near future. I wonder if his outlet is the same sort of issue.

You can do what I did. I have SmartClick dashboard display the Siren as a switch which you can toggle on/off.

1 Like

OK, so I keep running into dead-ends! I am now trying this on a Samsung Galaxy Tab 3 and having zero luck with Flash! I have installed Flash on the device, but none of the standard browsers will work; they all say “Flash not Supported” on the Dropcam tile. Flash is turned on in the browser, and I even tried “Always On” instead of “On Demand”. Once again I install Puffin browser (free, limited version) and the Dropcam feed works fine (well, except for the size issue I had on my iPad).

What are all of you using that supports Flash? I thought it was just stupid Apple products that didn’t support Flash!

It is more than just Apple products that don’t support Flash, almost all browsers are going away from it. I haven’t seen it work on an Android in quite a while, I know there are a few devices out there that are suppose to support it, or you can side load it or some other work around to use it.

I would suggest avoiding Flash like the plague if possible.

1 Like

It’s great that the weather tile is back and working again but has anyone noticed the lack of refresh lately? Mine says it’s 18 degrees out and it’s really 26.5! I’ve tried 2 devices and a reboot but still erroneous data.
Cheers

Anyone who is concerned about weather not refreshing due to scheduling issues is welcome to follow this thread.

In the future, I may rewrite schedulers to use external triggers instead.

1 Like

Thank you! So buried!

Hey Alex,

For the Sonos text any way you can get the text to scroll instead of having it go over the buttons?

2 Likes

Can anyone help me get a Hikvision IP camera working in SmartTiles? Maybe there is some trick I am missing? My camera is functional and viewable from the outside internet. I use NoIP.com for a Dynamin DNS address. That address works fine from a browser or any of the camera apps available on phones these days. When I put the address into the “Video Streams / Generic MJPEG video streams” section and then open SmartTiles, it appears to hit my modem or the camera behind it, and prompts me for a username / password. But no matter what I put in for username/pw, it doesn’t accept what I’ve entered and the login screen reappears.

Anyone experienced this?

@YEM Have you try putting the user name and password first
something like
http://user:pw/IPADDRESS:554/videostream.cgi?rate=0? i don’t know what model you are using? see if that works for you.

1 Like

@YEM H.264 and port 554 are for RTSP. SmartTiles does not support RTSP yet.

You can use java script to capture still image every 3 or 5 secs.

Or try below steps. Keep in mind that it might not work with all of web browsers. It work for me on Safari, but NOT Chrome.

  1. Log into your camera
  2. Change the settings for the substream H.264 to MJPEG. Main stream only support H.264
  3. Use http://user:pw@IPADDRESS:port/Streaming/channels/1/preview
2 Likes

@dchau11
@llcanada

Thanks for the info guys. I found the substream setting and changed it to MJPEG. Although I don’t know what that means. Do I have to point somewhere else to see the substream as opposed to the Main Stream?

And Dave, do I need to eliminate the use of port 554?

@YEM “Channels/1” mean for substream. For port 554, try to avoid it. It is the default transport layer port number for both TCP and UDP. You can use any port that you define as HTTP port for your camera. By default, the camera use 80 for HTTP.

Thanks Dave. I’m a bit noob at the camera stuff so I appreciate your time and help. Should I be able to use this URL in my browser to test to see if the stream comes up? (no I assume it doesn’t appear to be a proper url)

This is what I have inserted in SmartTiles (with a few pw / IP digits and letters changed around :slight_smile: ):

http://admin:zebra88@73.83.264.1:9001/Streaming/channels/1/preview

Is that correct?

This is my config screen for the substream:

@YEM Yep, you can test out with your browser first.

There are many people that use Foscam with Android tablets.

Please refer to this thread for video related information.

This should be doable with an iFrame, but at this moment I don’t have a plan to implement this.

1 Like

The greatest weakness of Dropcam is it’s dependance on Flash. Here it’s a common complaint and there is no easy workaround.

Does Puffin browser give a satisfactory experience when using SmartTiles?

1 Like

Yes, will add it to my list.

Which mount are you using for the iPod?

http://www.simplewallmount.com/

1 Like

What about a simple tile that let’s me add a url to an image? There’s a bunch of foscam code laying around that just refreshes snapshot. Cgi and doesn’t need any plug-ins to work.