SmartThings wifi won't create network

Hello! I’ve been trying for weeks to get my SmartThings Wifi set up. I have a ticket open with support and it’s been escalated but I haven’t heard since then. Basically what happens is I can go through the entire setup, but the device doesn’t actually create the wifi network. I think I’ve gone through the setup more than 50 times and spent about 7 hours trying to get it working. I’m able to get through the entire setup without errors, but at the end, the network isn’t actually created. I’ve tried buying and returning different routers and modems and can’t figure out why it won’t connect. I was on a Netgear CM400 modem and also tried it with a new CM600. My old Belkin router works fine. I’m on Optimum Online. I took the router to another house and I was able to set it up on the first try! But when I take it back to my house I’m not able to get it to connect. Now that the router is registered to my account, the status goes between “checking status” and “disconnected.” I don’t know what else to try… The next step would be to get a different mesh wifi system and just get the standalone SmartThings hub separately.
Any ideas? Could there be something preventing the network from being created or connected to?
Thank you!