Smartthings V3 and Ring Video Door bell 2

Hello everyone,

I’m new to the world of automated smart devices. I just purchased the smarrthings hub v3 and can’t add my ring video doorbell 2 to it (incompatible?). I have been searching around to see if there’s any other way to accomplish this.

I found some information about connecting the device through SmartThings Groovy IDE, under add a device.

I’m stuck at trying to add the doorbell and obtain the device network id. Can anyone offer any assistance?

If you use the new SmartThings connect app, you go to add (the + sign), Device, select by brand, select Ring, select Doorbell and then follow the directions. After you’re done, login into IDE with your SmartThings account, go to devices, select the Ring v2, click edit, change the Type to Ring Doorbell Pro and then you will be able to view the live stream straight from the ST app.

Thanks for the quick reply. I have tried to use the method above but i get the following:

The Ring account is up and running, correct? Perhaps try this? If not, you may want to contact support

Doorbell 2 is not compatible, stick to ring devices on this list. Model numbers matter.

Enter it like a V1 doorbell. Then after adding, switch to pro in IDE to get video in the app. Working for me like this.

Ring Doorbell 2 is compatible.

Live view:

Just change DTH to Pro

I have doorbell 2

Is this integration still working?

I have a ring doorbell 2, have tried multiple times to link to ST - have changed the device type to PRO, but same error in ST app - “The camera is unavailable. Tap the refresh button”.

If anyone could help me get this working, I’d really appreciate it.

Front Door Device Front Door

Name Front Door
Label Front Door
Type Ring Doorbell Pro
Version Published
Device Network Id 34611121
Last Activity At 2020-05-04 3:29 PM AEST
Date Created 2020-05-04 3:29 PM AEST
Last Updated 2020-05-04 3:31 PM AEST
Data * DeviceCheckTimeStamp: 1588570176766
  • DeviceFirmwareVersion: Up to Date
  • DeviceManufacturer: Ring
  • DeviceModel: doorbell_v4|

Try adding it as a version 1 and then switch it to a Pro in the IDE. That’s what worked for me.

Above don’t work, no matter what is picked, Ring will not authorize initial install…

And yes, it’s in my ring account and works fine.

Still working for me… And even shows the battery percentage