Can't get Ring (original) doorbell to connect to ST

I have two original Ring doorbells that are brand new, and I am not able to get either of them to connect with ST. I’ve had one before and removed it from the app before trying to connect the new ones. Has something changed that causes these not to connect? I don’t remember having a problem with the first one. FWIW, I used to have a now-deceased Ring Pro that also connected with no issues.

did you set them up in the ring app first?

Yes, they have been up and running for a couple of weeks with no problems. I just can’t get them to connect to ST. I go to Doorbells/Connect Now/hit the orange button and the light just cycles around without ever connecting. WiFi is fine. I can stand next to the router, across the room or in another room - no difference, won’t connect. I’m stumped.

Did you get prompted to login to your Ring account?

No, I didn’t.

One thing that I did notice was that I can’t remove the old Ring Connect smartapp. Could that be the problem?

If you open the Ring (Connect) is there an option to login or select your ring doorbells? If not, I suggest you contact ST support and let them work their magic.

1 Like

No, if I click on the Ring Connect SmartApp, it just shivers, tries to cycle and stops.

Go to the IDE, choose my locations, choose your hub name, scroll down and click on “list smartapps” . It’ll show you a list of smartapps, then click on edit and then uninstall Ring to start over.

1 Like

Thank you, thank you, thank you!! That fixed it - all my doorbells are in ST now and working!


Could you please give a few more specifics on going to the IDE to solve this. I ran into the same problem trying to set up my dad’s original ring doorbell with the smart things hub. Thank you!