SmartThings turns on one Samsung tv but not the other

I have a newer qn65q90 that works perfectly with smart things and Alexa control however my 2018 qn65q6 only works after I power it on with remote. Once powered on smart things and Alexa works fine. It appears as though the qn65q6 goes offline after powering off where my q90 never disconnects from Wi-Fi. Smart things used to be able to turn the tv on just fine. Any ideas for me to get the power on to work for my q6?

I have a little bit older samsung in my basement that did the same thing. I went into the apps on the television and installed smartthings. if you already have that then in the apps menu got to settings and find it and reinstall.

Thanks I tried that but still same issue. At this point I am about to replace one of the Samsung TVs in the room since I can’t find any workaround that works.

Have you tried the television help forum? They may just send you back here, but it seems like it would be worth a try. :thinking:

Also, if you like the television you have except for the issues of powering it on, another option might be just to get an inexpensive IR blaster that works with smartthings.

I have exactly this issue with one of my televisions, although it’s not a Samsung brand, and I use a SwitchBot mini hub just to turn it on.

Here’s an old commmunity article I wrote about that option. You don’t need to have a smartthings/Aeotec hub to make it work, switchbot provides its own cloud to cloud integration with smartthings.

Switchbot - Simple “power on” for some TVs (IR blaster)

And here’s the device I use, although you can use any IR blaster that works with smartthings.