Smartthings, Newer samsung TV, and Alexa smartthings skill

I’ve been fighting with getting Alexa to turn my tv on ever since I switched internet providers (Yes Alexa worked perfectly with my TV with the old internet provider). When I ask Alexa to turn the tv on, Alexa responds that the TV is off line. Alexa can, however, turn the TV off every time. Now, when I use the smartthings app on my phone, I can turn the tv off/on no problem. The interesting thing is, when I log in to the samsung smartthings on my laptop, the device shows off-line. I think this is key information.

This leads me to believe that the new internet provider (Shaw Cable) is blocking something, hopefully at their modem level. I’ve been thru amazon support, Shaw Cable support, and Samsung Smartthings support. No one can give me a hint as to what ports/protocols are used to communicate with smartthings.

I am going to order a edgerouter 4 and put my shaw cable modem in passthru mode so I can gain control of port and protocol forwarding and hopefully make this work.

I’m seeing a ton of complaints about the smartthings connector, but no one seems to actually want to dig in to the issue, including smartthings. Their support is all but useless, and either they don’t understand what I’m saying, or don’t care. The standard…un-install everything, and re-install answer over and over. Been there, done that.

Does anyone here have any experience with this issue. Any words of wisdom? I know this can get kinda technical, but that’s where I have found myself.

Don

I’m just another customer, but I’m wondering if the issue might be that you were switched from the old Alexa skill (which worked very well most of the time) to the new Alexa skill, which has had multiple issues from the time it was introduced. There have definitely been several people posting in the forum that they can’t get their TVs to turn on anymore. :thinking:

This forum was started a number of years ago so customers with the smartthings hub could help other customers. It’s not an official support channel. And most people here don’t have Samsung TVs.

Hopefully somebody who has an idea will respond here, but you might want to also post over on the official Samsung television forum, since employees do monitor that one. They may just send you back over here, but it’s worth a try.

Is your TV connected via Wifi or Ethernet?

1 Like

I wrote a driver for Hubitat that works (both wired and wifi connection). The problem is that if the TV is in standby, the wifi is off/disabled. The method to turn the system on is a Wake-On-Lan command - for 2016 and later models. This command is NOT explicitly address. Instead it uses the MAC of the device.

To add, there are different MAC addresses for the WOL (one for wired and one for wifi). Several possibilities:

  • Router does not pass through the command (security setting)
  • You have the incorrect MAC being sent
  • The device is on a different segment from the Router
  • The Alexa integration (by Samsung) is faulty (most likely since you are receiving a message so indicating)
  • Your TV is an earlier model (2015 and earlier - you are out of luck.,
  • Others that I can not understand.

Check:

  • Wired or WiFi. If wired, try wifi (wifi uses the default MAC).
  • Router security settings that may block some messages
  • Is your TV IP segmented from the base system (i.e., router has address 192.168.0.1, TV has address 192.168.50.22.
1 Like

You guys are the best. Thanks for the comments.

My TV is wired via ethernet, and it used to work fine. I’m going to move it to wireless tonight. I have good strong signal in that area so signal strength wont be an issue.

Any thoughts as to the router not passing thru the security settings? I’m not sure exactly what smartthings uses to communicate, so I don’t know what to look for. Thats why I was thinking of starting with a high end router to get control and see if I can see what the router is blocking in a log (Or maybe setting the cable modem in to passthru and using a high end router will just work with no other routing).
There’s no segmenting issue in my home, It’s all one network. No issue there. I do have a newer TV (Q70 I believe), so I’m good there.

I’ll report back my findings as I work thru this. It’s a hobby, so I’m fairly determined to find the issue.

Don

1 Like

Good luck Don, the ON command is something lots of us have been chasing for a long time

1 Like

I can’t find it on the new support site, but there was an article on the old ST support site that said some action like TV on/off only work properly when the TV was connected via WiFI. Seems quite silly, but my experience with my 2019 Q70 matches this. It works fine on Wifi, but I switched to Ethernet for a bit when wifi was having trouble and it alaways showed disconnected in he ST app when off and voice commands to turn on didn’t work. Got it connected back to wifi and it worked fine again.

1 Like

I have the opposite, wifi gives no on, ethernet gives on command after I clear a big blue banner saying your tv is off line, which it clearly is not completely because on works

I believe the issue with ON is multi layered due to different TV software, older 2016 2017 2018 tvs used a now outdated connection method, the Tv software is only supported for 2/3 years so no more updates to bring the older tvs up to current connection standard

Then there’s the 2019 2020 tvs, some work on off no problem using the new connection method and some just fail for on

Then there is the most confusing, new tvs using latest software Inc top of the line tvs, they might switch on but many don’t

The issues are different for each tv with multiple reasons

1 Like

One other thing. If you do not have a SmartThings hub, you may have a problem. The WOL usually works only when originating from the local LAN, not remotely.

You could also try turning off any firewall and test. Essential: Then turn the firewall back on again. It may point you in a correct direction.

The TVs don’t communicate with the ST hub at all, so it won’t make a difference.

I absolutely would turn the firewall right off for a quick test, but the cable company supplied modem/router does not seem to have an option for this. If it comes down to it, I’ll purchase something that does give me full control.

I found the firewall in the cable modem and turned it off ----->fail
I then found firewall logging with the firewall on, and the firewall didnt show it was blocking anything when I asked the TV to turn on.

I removed the tv from smartthings account (on the tv), removed the smartthings skill, removed smart things from my phone, and ultimately removed the smartthings account.

I then created a different smartthings account (Do not create the same account again, as I had tried this previously with no joy) and rebuilt the setup from there. It doesn’t take long.

Success! The tv now turns off and on. I tried the TV on both wired and wireless connection. Both work fine for me.

I had really gotten used to using alexa to turn on the TV group. It turns on and off 3 things. It’s nice to have it back.

1 Like

This is still a bit of a work in progress. Every morning the TV would either not turn on by voice command, or take minutes to finally execute the turn-on command.
I found that the Alexa device used was being a bit flakey with another device also, so I did a reset on it. I also went to the internet firewall and set the tv ip address in to the DMZ. I’m not completely happy about leaving the TV flapping in the breeze on the internet, except it still does have NAT going for it so hopefully its ok for testing. Anyway, the TV did turn on this morning quickly first try. I’m going to leave the TV in the DMZ zone for a few more days and confirm the tv turn on/off as it should. After confirmation, I’ll remove the TV from the DMZ and test again over a few days. Hopefully I do not have issues with someone finding the TV on the internet and figuring out how to screw with it. How an Internet-connected Samsung TV can spill your deepest secrets - Ars Technica OpenForum

After a week with the tv in the DMZ, it has worked exactly as it should.
Turns on first thing in the morning quickly, and has never failed to turn on via alexa voice command.

I don’t use the tv for any other smart features (HDMI to a computer is used) so I think I’m going to leave it in the dmz.

If it was me, I wouldn’t leave any TV in the routers DMZ. Because that makes the TV operating system accessable to hackers on the internet who can possibly hack into it and then get any usernames/passwords of the accounts being used on any of the apps installed that are logged into their services. Needless to say, the DMZ is a risky solution to just turn On a TV.

I use the wired ethernet connection on my Samsung QLED HDTV, but I rely on the attached Amazon Fire device (I have a Fire Cube) to turn On/Off the attached HDTV using the HDMI/CEC connection which is much safer than using a DMZ. The attached TV on the Amazon Fire device is also listed in the Amazon Alexa app as a Smart Device too. So, I can even use Alexa Routines to control turning it On/Off it if I want to without even using SmartThings. So, my Samsung HDTV is listed in the Alexa app twice. It’s listed as Samsung HDTV from SmartThings integrating, and again as TV from the Fire TV Cube’s HDMI connection.

1 Like