SmartThings Think's I'm Home and I'm Not


(Brian Engel) #1

So I was looking at my Mobile App today because my Away routine never triggered. I noticed that according to the app it thinks I am home (due to my mobile phone being used as a presence sensor). The thing is the phone is with me at work, 30 miles away! How do I troubleshoot this?


(Benji) #2

Check to see if the phone can get a GPS lock, force close the app on the phone and re-open it.


(Brian Engel) #3

I opened Google Maps, got a GPS lock on myself successfully. I force stopped my SmartThings app on my phone a relaunched it and it still shows me Present since 4:29pm yesterday


#4

This might give you some ideas:

However, given that there were major platform outages yesterday, it may just be something left over from that. I would definitely get in touch with support.


(Ben W) #5

You can also check live logging (from home) Kill the mobile app and restart it. You should get a message that Brian Mobile connected and a presence state.


(Rick S) #6

Android presence stopped working on June 8, well before the issues of yesterday for me and my wife both, about 15 mins apart. We both use Life360. I have deleted and recreated the devices, tried the suggestions above… Nothing

Opened a support ticket yesterday and so far, no response

Rick


(Barton.) #7

You might try an app called “Fake GPS” in the Play Store. After the outage the other day, the presence on my phones was messed up. Choose a place in the app that’s far away and then check Google maps to see that the fake GPS shows your new location.

Stop the app, and then ensure that you’re at your correct GPS location, then see if Smartthings registers you at home.


(Ash (www.smart-dots.com) / Ashutosh Jaiswal) #8

Restart your phone…and re-open ST app…It usually solves the problem.


(Rick S) #9

Mine was so screwed up that I couldn’t even delete either phone as a device, until I changed the device type to something else and added the phone to a Room. Once I did that I could delete them.

Now, I recreated my wifes device using Life360 and presence registered fine, will see how it goes tomorrow when she leaves.

Mine on the other hand, deleted and recreated 4 different times and still wouldn’t show as present. Then I changed the name of the device and ding, ding, ding, that worked. Now both phones are showing as present.

Tried rebooting my phone, hub, app…

The IDE and App are running slow with many screens

Oh well
Rick