SmartThings Station if you already have a V2/V3 hub?

Did you install a custom edge driver for it on your V2 hub? Or install one from the SmartThings beta channel?

1 Like

I got it to work after some tinkering. The factory firmware seemed to originally pair the device with a cloud driver, which I had to delete from the graph. I enrolled the hub and drivers from the official beta channel and repaired. It seems to work now!

Odd thing is that the official non beta driver isn’t available on the station for some reason.

which driver did it end up using from the beta channel?

zigbee switch

What is the fingerprint for that device? I’d be curious to see if it’s in the beta channel but not production.

1 Like

It’s probably in the official there’s only one sengled switch fingerprint SmartThingsEdgeDrivers/fingerprints.yml at 179cfb905c3f44aee1406a67c12c39790a862cec · SmartThingsCommunity/SmartThingsEdgeDrivers · GitHub. I don’t recall having to do anything on the v2 hub to get the official drivers; I think they were a part of one the firmware updates. Maybe they are behind with adding station to their roll out of all things edge drivers.

Hello there, I have been using smartthings for years and years but I am still strugling a lot with the change from the old Smarttthings IDE ( to the new… edge drivers and stuff. I have a hub V2… and I also have a Station (I got it in an event… as I live in Korea), but I have been strugling to get to work properly my 3rd party zigbee devices… and tasmota, pairing them with the new Station.
Right now in the mobile app of smartthings, I have the Smartthings Station with the list of all the devices that are connected trough it (I enrolled some edge zigbee multi switch drivers and tasmota drivers in order to connect them), but when I check in the, it says that my station has no device connected, and in my device lists, all the devices that I have connected to the Station say “Execute location: Cloud”, and I cannot see the details od the Data, zigbeeNodeType, etc from any of those devices.
Can someone point me towards… how to check if I have done something wrong? :smiley:
I don’t know how to manually install edge drivers… is that neccesary? what are the beta drivers? the only way I have installed edge drivers is by clickin on the respective links and enrolling them, like this one for tasmota:
Channel and Drivers Web UI

Installing drivers in that way (With that link) means that the drivers will be cloud based? or do they install locally in my Station?


I suspect the only thing that is ‘wrong’ is that you are using the IDE to view what is going on. The IDE is a development environment for the legacy system that is being phased out. It only really understands the legacy devices. You really need to be using the current tools, which means the mobile apps, the web client (, the API and the CLI.

A number of users find a community written app useful - Todd’s API Browser+.

Unfortunately I have to dash so I can’t add the links at the moment.


Man that was super helpful!!!
First of all, I have been searching everywhere for the web client! That is so so useful! Thanks a lot!
Regarding current tools…I have battled a lot with the “developers workspace” but I just can’t wrap my head around how to get anything at all from those sites… :frowning:
I have read about the CLI, but I have not tried to make it work actually… because I cannot understand why they would downgrade the system and leave us without a user interface :cry:… I manage linux servers btw… is not that I hate a command line… but I just dont want to take the time to learn a whole new dictionary of commands to do something I used to do seamlessly in the old IDE :stuck_out_tongue:
Anyway… my main goal is just to check the zigbee network status… and check which devices are routers… and relaying with what… to find out why some switches keep disconnecting :confused:

This may help:

Life after the IDE: Questions and Answers

1 Like

They seem to be skipping the station with firmware updates so far. I don’t even think it’s on the official smartthings edge driver channel yet. Wonder if they forgot about the device already or if they are planning to do updates later.

Well the Station did get a couple of firmware updates. I think I was one of the first people to get a Smartthings Station (being that I live in Korea and frequent some samsung falaxy stores… and I got it for free in a launching event), it was the first or second week of Febrarury… and well, the first thing I did was trying to install the tasmota edge driver I had in my hub V2… and after loggin in, I could see in My Humbs… the Home Hub (that is my V2), and my SmartThings Station… and when Clicking on Enroll under SmartThings Station… a message would popup that said… “SmartThings Station does not support Edge Drivers”… XD… I tried for like 2 or 3 days… with different edge drivers… same results I could not believe it XD
But anyway… I activated automatic updates… and after a week or so… I tried again… and it worked :stuck_out_tongue:
Anyway… Since then I am still using my Hub V2 alogside my Station… and have been balancing what devices I have installed in one or the other… so to test if which one works better. So far… mmm… I think Station maybe works faster… for Zigbee devices that relay routers… but I get the feeling that for sleeping end devices (battery powered buttons), it takes a bit longer in the Station than what is takes on the Hub V2. Not to mention when the devices are crossed (one on the Station and one on the Hub…), there is like a 2 or 3 seconds delay for turning on and off…
In any case… all I want is to be able to see the zigbeeNodeType and maybe the route of the zigbee devices connected to the Station… still no cigar.


It’s definitely using the standard SmartThings Edge Driver Channels (and customs ones if you want)

1 Like

My station pre latest firmware was installing switches using dth. I can try re-ading to see if it’s using the non beta channel.

Yep, I see them now on the latest firmware. Had to remove the beta channel for it to appear. Thanks!

1 Like

How do you know if it is the beta drivers or not?
I have not manually uninstalled any drivers and my Zigbee Switch drivers say this:

Use the API Browser+ and see what channels your hub is subscribed to by looking at the installed drivers.

Yeah, everything points towards using API Browser+ as the solution for all I need… I haven’t really taken the time to analyze that.
But… has it been unequivocally established that API Browser+ is safe to use? :stuck_out_tongue:

You don’t need to use the API Browser, you can open the app, go to devices, and open your hub. Then go to the “driver” page (use the 3 dots). It should list all the drivers and channels you have or are subscribed to.

1 Like