SmartThings (Samsung Connect) UI Update - Android 1.7.27-25, iOS 1.6.27

I am not seeing device history even though it is toggled on.

if I force quit the app and open it back up - the Activity screen starts showing items

I went as far as an app uninstall/reinstall and still no device history. Automation history is there. It did work until I toggled off/on device activity in history settings - its like the ‘on’ trigger of the toggle is non-functional.

Notifications seems to be populating correctly for me. For Activity I have one item for today and prior to that I have nothing since mid evening on 2/15. It says last sync was now.

I’m having the same issues with recording of items not saving as well as removing items from favorites coming back. So annoying after spending a bunch of time getting it look how I want with my 100 devices. Twice…

I had 64 items well integrated and working well on SmartThings Classic until I made the mistake of opening the latest version of the Samsung Connect app. BIG mistake.

On opening the Samsung Connect app it created a new location and moved all but the shades to the new location (Home). It also made available only 16 of the 64 items to be manually controlled. There is no way to add to rooms, scenes or anything I can actually use to control beyond the 16 units. Oddly if I want to create automation I can include all of the other controllers but can’t operate manually any that weren’t the original 16 transferred.

My goal is to stay with the classic. I would like to consolidate all units back to one location since I only have one house. If I delete the newly created location what happens to all of the items associated with this location?
Is there a way, short of talking to the impossible to reach support, to re-associate the location to the old location? Has anyone solved this problem?

One option is to go through each of the 64 items and remove them from the network and reconnect them and redo the automations with a clean location. A fresh start. I would rather not do that. I’d like to find a way to revert to what I had three days ago.

Your best bet would be to contact ST support at

I thought that might be the case. As I write this I’ve been on hold for 1Hr and 31 minutes. Before this, I was on the phone for one hour and was disconnected. Kind of a frustrating experience.

I bet it is frustrating. The extra home Location has been seen before but usually it is empty and easy to remove but sounds like you still have a large number of items in each. I would not delete anything on your end. Speak with support first and see if they can merge everything for you and sync your devices.

and @JDRoberts responded to your other post :slight_smile:


So the good. My Samsung washer and dryer look real nice in the new UI. Ha. More support for custom automations like MyQ lite and Konnected.

The bad. Ecobee remote sensors, which I have nine of, show motion primarily instead of temperature. Also no apparent way to add devices allowed for Alexa then going back into the classic app and editing there. No external app/API for SHM (so ActionTiles can’t change the mode). The top third of the home screen is pointlessly used by empty space.

It’s getting better but it seems to be taking a really long time to just get up to the same usability as the classic app.

1 Like

I’m confused. Are you able to use both simultaneously? Does the new app “migrate” stuff, thus breaking custom stuff that can’t be made visible?

Traditionally I think of a mobile app as a vehicle for CRUD from a database. The app itself shouldn’t actually hold anything real. So based on this I would expect both apps to be able to coexist but the new app just wouldn’t display what it isn’t able to figure out.

I seem to read conflicting reports of this being true but then others saying their house caught fire after installing the app.

Can anyone unconfuse me?

@Brad_ST - I currently have 22 groups / rooms configured in the classic app (I eliminated one compared to previous posts). The 19 highlighted ones got ported over to the new app but there is no trace of House, Utility Room and Master Suite.

Before I start deleting and re-creating, I wonder whether this is some bug that you (@Brad_ST) would like to look into. My plan was to re-create Master Suite in the new app and move all the devices already in that group on the classic app to it. I then hit the arbitrary and silly 20 room limit so I am hosed for the remaining devices until ST increases the limit or provides some alternative solution to unclutter the rooms. The need for extra groups that are not actual rooms is to hold devices such as leak sensors and smoke detectors that would otherwise just clutter rooms where I mostly want to easily find switches/dimmers. Please get rid of the 20 room limit!

1 Like

Plus automation are still broken. They work & they dont work & notifications still be a little screwy (missing events). I understand the developer’s must be very busy but i wish they could acknowledge at leat they are woeking on it. Does samsung want us to start using the new app or just ignore it?

How did you manage 9 when they come in pairs. :thinking::nerd_face:

I literally have to look at the screen for 2 minutes before I am able to scroll through the list of devices. It just says checking status and the screen is stuck.

Also, why can’t you see if stuff is on/off without having to go into the tile? :thinking:

I just don’t understand…I am literally flabbergasted. :weary:

Meanwhile, everything is working perfect for me in the Classic App. :man_shrugging:t5:


Nice plant… lmao


Hey - don’t knock the plant! It probably took months to choose/discuss and finalize the use of it. :slight_smile:


So one came with my stat then I bought a pair then my company started to rep them so I got two more pairs for free. :slight_smile:. Then they stopped repping them (low sales) and I picked up another pair when Lowe’s had them on sale for half price.

So 9 and can probably use 2 more.

When I open the app it frequently gets stuck, I guess while it is updating statuses, and makes it a poor user experience. I believe the classic app, at some stage, was also having issues where things were not cached (or whatever the issue was but it seemed like it was a caching issue). Hopefully this will get addressed in the new app as well because it is super annoying.

I’ve noticed that some devices with custom DTHs just have a dash where the status usually appears. With those I have to open the tile and then control it from within. I am guessing there is some extra code (OCF?) that needs to be added to the DTH to make it work properly. I have not checked to see if any of my custom DTH devices work properly, but if they do, then it may be simple to update the ones that do not by copying whatever additional code is in the DTHs that work. When I get some time I’ll tinker with it.

They show on/off, open/close, etc on the tile if you use a default handler or properly coded custom handler.