Smartthings Multipurpose Sensor stuck open but is communicating temperature


#1

Hi,

I have had a new multipurpose sensor installed on a door for the last week or so and it has worked flawlessly reporting open/close status, active/inactive status and temperature. Today it suddenly started showing it’s open and nothing I do will make it show closed when the door is closed.

The magnet works fine, I have rebooted the hub, the temperature is being reported as it changes, no issues there. For some reason, the sensor keeps showing active and open even though it’s communicating regularly with the hub. Nothing has changed in my configuration or network for the last few days. Any ideas what may be causing this?

PS - my router is at least 20 feet from the ST hub, just like it has been since I set it up, no change there.

Thanks in advance!


#2

Several people have reported a similar problem. First, make sure you report it to support.

Second, there are two totally independent separate causes for the symptom.

One) some of these particular sensors seem to have a problem with battery management, and when the battery goes below 66%, they stop reporting motion. The easiest way to check if this is the problem is just to put a new battery in it. If that fixes the problem, then definitely report that to support.

Two) if you have any zigbee lightbulbs, of any brand, connected directly to the smart things hub, The hub will identify these as repeaters. Unfortunately, however, they seem to just missed some messages from other types of devices. This then causes the devices to not be able to report. They seem to be OK repeating the messages of other bulbs, though.

This is a really weird problem, and no one has been able to nail it down exactly, only that there are members that have had problems with zigbee motion sensors not reporting, they then removed the zigbee bulbs from their network, and the motion sensors started reporting again.

Note the bulbs which are attached to a Hue bridge will not cause this problem because the bridge forms its own mini network and those devices will not be selected as potential repeaters by the SmartThings hub.

Not sure either of those has anything to do with what you’re saying, but it’s worth investigating.


(Ben) #3

I realize that my response will be pretty much like “Well dah…yes”, but have you tried pulling the battery out of the sensor, waiting for a minute or two, and then replacing it?

If that doesn’t work, maybe try doing a reset:
YouTube video on how to reset sensor


#4

Thank you both so much for the super quick and helpful responses!

The battery is currently reporting 100% and sensor is about a week old, so hopefully that’s not the issue. I do have 2 GE Link Zigbee bulbs at the moment, but they are clear across the other side of the house from this sensor, so it’s unlikely that this sensor is using them as repeaters. No hue bridge here so we can eliminate that as well.

I tried several battery pulls and also several sensor resets like shown in the youtube video (that was really helpful, I didn’t know how to reset properly), but these didn’t work either. Finally, after the 5th or 6th battery pull, it kicked off a door open notification! So I knew it was now working properly. I took the sensor back the mounted location, closed the door and the app immediately showed the door was closed.

So the problem is solved for now, but unfortunately I’m not able to pinpoint an exact cause… The final solution was multiple battery pulls if this helps anyone in the future.

Thank again!! I’m just starting out with ST and this community seems amazingly helpful :slight_smile:


(Ben) #5

Good deal! Keep an eye on the device for the next several days/weeks.