Open / Close Sensor stuck on open


(Mike Barton) #1

Pretty much as title.
I have tried deleting and re_adding, pulling battery and resetting.
Moving the hub just in case and it just shows as open.
At the moment it’s on the kitchen counter with the battery out but if I go into the Smartthings app it still shows as open and the battery at 88% no matter how many times I hit refresh.
That cannot be right.
It has worked fine for the last 3 weeks.
Any suggestions would be much appreciated.


#2

I had to take the battery out of mine and fiddle with it the other day. It was stuck on closed as the battery contacts appeared to have lost, well, contact…
The battery had plenty of charge.
Been fine since.


#3

This might be of interest:


(Tim Slagle) #4

Try this.

open up the device and hit the little button 5 times. That forces the device to find the strongest nearby router.


(Mike Barton) #5

The battery has been disconnected all weekend but in the app its still showing as working and the battery charge at 88%, that’s surely got to be something not updating in the app or at the server?


#6

Specific brand and model?


(Mike Barton) #7

Samsung Smart things sensor that came with the kit


#8

In the UK, based on forum posts, there were some manufacturing issues reported with that model. I would definitely get in touch with support.

As far as the values that you’re seeing, that’s just from the last time the device reported. SmartThings doesn’t do a wellness check to flag devices that haven’t reported for a while. They just save the last report they got.


(Ray) #9

Does this work for all Samsung zigbee devices?


(Tim Slagle) #10

It works on second gen devices like the open/close sensor.


(Ed) #11

Drats - just had this issue twice. Hopefully it’s not a manufacturing issue.

Have removed some batteries - those in multi sensor is too darn difficult to remove. Unplugged hub and going to wait for min 15 mins. Hope I’ll see improvement tomorrow.


#12

In order to get the neighbour tables to rebuild, it is important that the subsidiary devices like the sensors remain powered on while the coordinator, in this case the SmartThings hub, is off power for at least 15 minutes.

the idea is to get the end devices to go into “panic mode” which will cause them to then rebuild their address tables once the Coordinator comes back online. If you have everything off power at the same time, the tables will not get rebuilt. It is the sensor’s inability to contact the hub that prepares it to rebuild its neighbour tables.


(Ed) #13

Thanks @JDRoberts.

This was what worked for me (so far …). Powered down hub for a good hour. Noticed sensors all not working after reconnection+1 hour - ie contact sensor saying closed despite me physically away from magnet. Tapping on it should caused activity to register but didn’t.

Took batteries out and reset while close to hub. Confirmed working. Brought it back to desired location and re-confirmed with the 5 button presses per @slagle’s method. Fingers crossed.


(Mike Barton) #14

Mine is still playing up big time. Motion sensor has worked flawlessly since day one but the open/close sensor has spent more time not working than working and is the reason I am refusing to invest in any further SmartThings kit.
Reliability is key for this.


#15

I am facing the same issue. Everytime I open or close the door sensor gets active however the actual status (open/close) is not changing.

Facing this issue since last month. :sweat:


(Wayne) #16

Hi @vlad, here’s another one exhibiting the same problem I’ve been discussing with yourself.


#17

I’m having a problem with one of my sensors as well. I’ve tried taking the battery out but no luck. It’s stuck in the open state.

I have a Samsung multi sensor. Have not tried deleting and re-adding yet because I have like 8 smart apps tied to it and it would be annoying.


(Aaron S) #18

Have you tried adjusting your Insecure Rejoin settings yet? If so, feel free to shoot a note over to support@smartthings.com (and reference this thread so they have some background).


#19

I pulled my current setting and it says Unsecure Rejoin is enabled


(Aaron S) #20

Shoot a note over to support@ with the name of the sensor and approximate date/time you last saw it work correctly (if ever)