SmartThings Motion Sensor won't re-connect after battery change

Had a battery die completely in ST Motion Sensor…2016 version from what I can tell. Changed the battery and it wouldn’t pair to the hub. Reset device and removed from the list of Things to start fresh… Nothing.

Using the CR2477 as per device requirements. We have changed this battery many times before with no issue. This is the first time it died completely before changing it, but I don’t see how that should matter.

Holding the button gives two blue flashes, no red as the FAQ says, but it sat trying to connect for thirty minutes and it still didn’t show up to connect it.

Please help! I’m being forced to use the actual light switch to turn on my lights! The horror!

Have you tried pulling the battery and holding the reset button while inserting the battery back in?

Yes, multiple times. Just sits there flashing two blues every three seconds or so.

A few things -

First, I appreciate how rough it is to use the switch. My husband doesn’t always get that. :slightly_smiling_face:

Second, is there any chance that you’re up to 32 zigbee devices on a v2 Hub (I’ve heard, but can’t confirm, that it’s 64 on V3, I have a V2).

Finally, I’m finding that in the last few months there are times that the hub just won’t pair anything (it’s like it wants a little time alone). I try it a couple of hours later and it works. My hunch (absolutely unproven and with a sample size of 1) is that it has something to do with the switch over to the new API.

Hope that’s useful. I’ve been going through the same thing where older devices that used to be solid are no longer reconnecting for a while. That said, they’ve all come home in the end.

Good luck!

Here is some useful info from SmartThings support:

How many devices can be on a Z-Wave or ZigBee network?

  • Z-Wave: Up to 232 devices. The controller counts toward the total number of devices on the network; in other words, up to 231 devices could be connected with a single SmartThings Hub.
  • ZigBee: ZigBee networks do not have a concrete limit on the number of devices. Some users may have hundreds of devices, or more, on a single network. However, larger networks will require wireless repeaters to ensure connectivity and optimal signal range and strength.

I have over 40 Zigbee devices with no problems.

Thank you, but I don’t think the number of devices is the problem. We have not added any additional devices since initial installation, and this is the first time we’ve had an issue after changing the battery.

I have attached a picture of my hub for reference. I will add a picture of my sensor in another post (new users can only attach one, sorry).

Here’s the sensor.

Thanks! We tried resetting the hub this time and left for dinner. Nothing.

Mind you, this has been a month or more that we’ve been trying to finagle this thing.


I have had success with contacting SmartThings support directly when i have issues.

Thanks. I sent an email just a few minutes ago. I don’t expect to hear anything back soon…lol

Maybe it’s just a bad sensor. It does happen. Have you tried another one?

No, I don’t have another one. You could buy me one, though, if you want.

@1mike4many Maybe I needed to be clearer. The limit is 32 for V2 If you don’t have mains-powered Zigbee devices such as switches or plugs that can serve as repeaters and extend the mesh, thus increasing the amount of devices you can add (theoretically unlimited). Anything powered by batteries will not repeat. I’m assuming that you have some plugs or powered switches (if V2) or have V3, which has a 64 direct-connect limit.

Anyhow that doesn’t seem to be the issue here.

I had this problem with an earlier model of the Smartthings Multipurpose sensor this week. I finally removed the device from my account and added it back. It worked.


We have already removed the device.

I’m having the same problem with the multipurpose sensor and I’ve even removed it and tried to add it but it doesn’t add properly just says checking status.

I don’t even get that far. Hub blinks green, sensor blinks blue, app searches incessantly and says it’s “taking longer than normal”.

My motion sensor is next it’s been at 1% for weeks but I’m not touching it until I get this figured out :confused:

I would change the battery before it dies completely. I really think that had something to do with it.

I will your probably right.

this is what it says when it finally connects