SmartThings Motion Sensor Help

Just bought 3 motion sensors. I’ve been using automations on all 3. The ones for my bedroom and master bath no longer turn the lights on when motion is detected. The app shows that they’re detecting motion. They just won’t do anything else. I’ve deleted them in the app and re-added them. They still won’t trigger the automation. Any suggestions?

Take the battery out and then put it back in for a reset. Try a new battery as well. If not chat with Tech Support through the ST application.

Lastly…use WebCore.

Basic troubleshooting: If the app shows that the motion detector is detecting motion, then the issue is not with the motion detector.

Here’s the chain, simplified. Motion detector detects motion. It sends a status update to the hub via zigbee or zwave protocol. The hub receives the status update. The hub/app then shows that motion has been detected.

You are here.

From here, the automation that gets triggered by that status update has to kick in and do whatever it’s supposed to do - in this case, turn on a light.

If the automation does not kick in, then there is an issue with the automation.
If the automation kicks in but does not send the command to the light, then either the automation has an issue or the hub has an issue… or the light’s DTH has an issue.
If the light receives the command but does not turn on, then there is an issue with the light itself.

I had a SmartLighting automation with a motion sensor conk out a few days ago. After testing each component on its own I deleted that automation and re-created it, and it now works fine again.

Joseph,

 I did remove/reinstall the battery.  That was one of the 1st things I did.  I apologize for not stating that.  I was on the phone w/ someone when I made the original post.  Still the same issue.  This is brand new out of the package.  The app shows the battery is at 100%.  Forgive me as I'm new here, but what is WebCore?  I see it's another community.  Now the app is showing that it's offline, but yet when I just got up the sensor triggered the lights in my bedroom on.

Glen,

 It might have something to do w/ the lights.  That is sure a possibility.  I have a mixture of Philips Hue and Sylvania recessed color lights.  The Sylvania's go offline a lot.  I have to remove and then add them again for them to work.  Just a few mins ago in the ST app I had at least a half dozen of the Sylvania lights w/ and exclamation point next to them.  Now everything is fine.  It may have something to do w/ my internet as well.  I don't have the fastest speeds (max of 24mbps DSL) and it tends to slow down (usually late at night).  Once I get high speed internet that may cure some of the issues I've been having.  I have deleted the automation and it's been the same.  I'll keep messing around w/ it and see what happens.  Still waiting on Comcast to drill under my road and run cable.  It was supposed to be done 3 days ago.  I'm hoping that will then fix my issues.  

-Rob

All the sensors are working now. Except that they come on outside the times I have set specifically in the automation. Basically these things work when they want to. I’ve removed the battery and reset the sensors and after doing so nothing happened. Except during the day do they come on when I have the automation set between the hours of 4:30pm-7:30am. The bedroom sensor doesn’t seem to want to work at night. The other two work as advertised. Is there something I’m missing here? The only thing I haven’t tried yet is resetting the hub. Which I’m not sure I want to do as I have a whole home full of lights that I’d need to add again.

What app are you using for turning the light on with motion? The Smartthings Smart Lighting app?

Yes! Sorry I forgot to mention that. This thing is just random. It seems to be working fine now like it was when I first set it up. It’s just that it’s not triggering at the specified time. It just triggers all the time. I just want it triggering when it’s dark out.

You could use the Smart Lighting app like this.

This is how this is currently set up in my app. I’ll try it your way & see what happens. I just attempted to add that automation and it won’t save. It keeps saying ‘Error saving page’. I’ve deleted the sensor/automation and re-added the sensor again but it just doesn’t want to accept the sunset/sunrise automation. It keeps giving me that ‘Error saving page’.