SmartThings motion sensor automation notification not working

Hi. Just bought the V3 SmartThings Hub and IM6001-MTP motion sensors. I’ve got a load of other kit too but that’s irrelevant for this query. I created a very simple automation in the SmartThings app that when the sensor detects motion, to send me (the only member) a notification. The Hub is ethernet wired. The sensor is right next to an access point so wifi signal isn’t an issue. The Hub and access point are on the same network subnet. There is no access duration set in the automation. I enter the room and I can see in the app that the sensor is detecting motion, but I get no notification. The automation seems to want me to select a camera and send a pic to my email address. Is this the only notification it can give? If so why ask me to type in text for the notification? Any help/advice gratefully received.

Welcome! :sunglasses:

Hopefully others will be able to help you with the automation. If you can post a screenshot of what you have set up, that will help.

Meanwhile, one very important thing to know about your system is that the hub uses different communication protocols for different devices. Your motion sensor is using Zigbee, and doesn’t use Wi-Fi at all.

Zigbee is a low power protocol particularly suitable for sensors. However, it is in the same frequency band as Wi-Fi, so it can get pretty easily drowned out by Wi-Fi which is a much stronger signal. For that reason, it is best to keep your Zigbee devices as far as possible from your Wi-Fi transmitters, particularly your Wi-Fi router and access points.

I don’t think that’s what’s going on with your situation, but I did want to mention it.

1 Like

I don’t know what happens if you add a pic, but without one the text should be sent to your phone as a push notification.

Hey there!

Does this behavior occur on any of the other sensor devices you mentioned, when you set up an Automation if condition of Motion is detected, then attempt to trigger the Push Phone Notification? If there is no request to attach a image, you should receive the push notification unless notification settings have been turned off or silenced.

Have you ensured that Notifications are enabled on your phone to receive the push notification?
Smartthings Push notification for Andriod 10 devices would be under Settings>Smartthings App>Notifications>Smartthings Notification Category to ensure that it’s enabled.

I hope this message finds you well!


I solved it in the end. It seemed to be an Android thing. After making sure ST’s notifications were switched on in the settings, it still wasn’t working, but on deeper investigation, I have an app called Clean Master that has a lot of tools to save battery, space, RAM, etc. In the Notifications setting, you have to turn ON the apps you want to receive notifications from. The default is off. When I did this, the notifications come flooding in.

1 Like

Thanks for keeping me updated, I’m glad that you were able to resolve your concerns by adjusting the notification settings. Enjoy your new device(s)!

1 Like