SmartThings Login Issues

I’ve been trying to connect IFTTT with ST for a few days now and it give me an error when I try to connect or login to ST. " Couldn’t load webpage The webpage didn’t respond to the request in time. IAMUSSauseast1_1676393269330_99999-4439554273.999 ". I get this error directly from the Samsung login as well, it flashes the 2 factor send code page, but the loads the above message.

Is there a fix for this, or am I missing something very basic?

I’m getting this tonight when trying to login to the IDE to reboot my now broken smartthings hub. Clearly Samsung screwed the pooch on multiple things here. Absolutely pathetic…

Well, at least it’s not just me? Lol. I found a work around for my problem to skip SmartThings all together, but wonder when this issue will get fixed as I cannot log in to the IDE interface either.

1 Like

I’m strongly considering switching to Hubitat at this point. Between stuff like this, and the absurd z-wave issue last night, it’s clear they don’t test things properly before releasing them for production.

Switching would be an absolute bear, but the work seems more and more worth it as the flakiness of Smarthings keeps increasing.

have you tried a private/incognito tab in your browser when logging in to IDE to see if that works? (will not work with linking IFTTT though from 1st post)

I just tried again and can login and link in IFTTT as well as login to IDE now.

1 Like

Yep, just tested it, and it’s currently working. The whole system was basically FUBAR last night.

1 Like

I get a similar issue recently trying to login to account on Firefox browser on a Mac. It skips past the verification page and lands on a page giving this error.
Couldn’t load webpage
The webpage didn’t respond to the request in time.
※ IAMGCSaeucentral1_1678552384642_99999-0206401294.999

Has anyone had a similar issue and a resolution?
thanks, Ang

what is the exact login page? I just tried using troubleshooting mode in firefox to disable all themes and and extensions but didn’t work.
I also cleared all the history and cookies for and tried using a private window.
You can see from the history it tries to load the verification page but fails.

It works on Chrome


I am able to login from both FireFox and Chrome.

if you continue experiencing issues logging in, you may want to contact Samsung Support.

They are pretty useless. They just drop the calls pretenting they can’t hear you and send a survey.

I am at a loss. it works on Chrome for you but not FireFox and you disabled all the extensions in Firefox to boot. Not sure what to do at this point. Maybe try clearing data for both Samsung and SmartThings… but I don’t know. close/reopen firefox if you haven’t already.

Yep. Done all those in above post