SmartThings integrated with Arlo, recordings stopped

Hello, first post.
I have 2 Arlo Q’s (looking to get 2 more) and a Arlo Pro. Before integrating them with ST hub they used to record 15 sec video if there was any motion detected. After the integration I still receive the alerts but there is no 15 sec recording.
I have also set it up that when I arm(arned away) the cameras from the ST dashboard the cameras will record for 1 minute if there is an intrusion.
Initially i got the cameras to check up on my puppy, so there were multiple 15 seconds recordings which I am not worried about since the Arlo gives you free cloud recording for 7 days. After the integration, even if the house is not armed, I would get the alerts(which I like) but the Arlo is not recording the 15 second motion.

Check and see which mode is active on the Arlo app. ST integration creates a “Smartthings” custom mode that leaves Smartthings in control of the cameras.

So, you now either need to set up recording in the Smartthings app, or switch the mode to your orignal armed/away/custom modes.

1 Like

I am not sure what you mean, if i leave ST alone and turn on the cameras manually through ST or Arlo app they alert me but dont record. The master room camera I turn on when I leave and off when I get home, the outside Arlo Q stays on 24/7, it alerts me when there is movement but it doesnt record like it used to when it was not connected with ST.

Also, on ST the Arlo base shows as OFF, I am not sure what that means, I am afraid to turn it ON as I am not sure if the alarm will sound.

I mean in the Arlo App, in the Mode section, what mode does it say it is using. If it says “Smartthings”, then try switching it to armed.

Or go into the settings for “smartthings” mode and turn on recording for the cameras that you want to record.

I prefer to use Arlo’s settings to control my recording as I have found the smartthings triggers and controls to be a bit more wonky.

So this is what I mean, you can see the alerts on the front page, before the integration I had these alerts and the library had all of these recorded on a 15 sec video. After the integration I get the alerts but the library is empty.

unfortunately when I check the library it’s empty.

Did you ever go and look and see what the active mode is? Just because it detects motion does not mean that particular mode is set up to actually record.

1 Like

You are a genius! You were right it was set to do nothing. I set it back to record. Thank you!!!

1 Like

Yeah, every now and again the mode change gets all wonky. I’m not sure if this is a ST issue or just how Arlo - or a combination of the two. But this is maybe the 3rd time its happened since I added Arlo to my system last fall.

Just this morning, I checked mine which was also not recording after the 6th. No big deal - go into MODE, see that each camera now has DO NOTHING instead of RECORD VIDEO.

But then I noticed something else. I had added a new camera over the weekend and I’m not sure if it messed with it more - but now it was set to WHEN FRONTDOOR CAM DETECTS MOTION - BACKDOOR CAM RECORD VIDEO. Each camera (there are 5) except for one of them had its motion detector cueing a different camera’s action.

Seriously, I’m glad I noticed that. Otherwise it would’ve been really confusing. Not sure what was going on there - but if you notice you’re getting notifications and no recordings in the Library - check your mode settings. Or just full on take them out of CUSTOM SMARTTHINGS MODE for a day or so.

I would not have known if I had not had the exact same problem

I’m getting same issue. Rules in Arlo app keep getting reset. Think I need to do all the video control from CoRE. Just need to work out how to do that

Smarthings created a custom rule on my Alro page. I changed the rules to allow recording, but it has not recorded anything, just detects motion and sound. I can not change the recording settings with smarrthings because smartthings does not have a way to edit the recording times. Please assist in resolving this issue.

BUMP. Same here. CoRE doesn’t have the record capabilities for the Arlo cam. It just detects it as a switch and a motion sensor.

Has this been solved. I’m looking to get my ST intergrated with arlo pro.

Not that I’ve witnessed yet, my system armed today like normal when I left and the settings all reverted to the old default values again as they have for some time now. My system does record though but those times are set in the SHM not in Arlo settings.

I have the Arlo wireless cameras. The ones that take cr123 type batteries.

I have noticed that when the Arlo mode is set to SmartThings each active camera will reset such that the push notifications will fire and motion will do nothing.

This is bad because I would expect the settings not to change or at the very least continue to record rather than do nothing. I will refer to this as “resetting”

I have found that certain activities performed on the SmartThings app will Cause a reset

  1. intruder alert fired
  2. changing SmartThings’ version of the camera name
  3. changing the motion sensitivity

Interestingly enough, Turning the camera on and off doesn’t reset anything.

As I continued to explore this it seems like any time SmartThings tries to override Arlo camera settings it will reset.

Intruder alerts will tell SmartThings to tell Arlo to record a 1 minute clip followed by a reset.

I found a workaround that works for me that avoids the resetting.

I choose arlos “armed” mode. And modified it so that it is set to record a video and without push notifications whenever a motion is detected.

SmartThings is still able to use the camera to detect motion and fire an intruder alert. It will record a clip with a length that depends on the armed mode settings in Arlo rather than SmartThings.

What is good is that nothing gets reset so further motions will make the Arlo camera continue to record. Most burglaries take ten minutes so having several small clips after a span of ten minutes is more beneficial then a single 1 minute clip

One more thing. I kind of missed the push notifications so instead of making Arlo fire them I set up a “Notify Me When” smart app in SmartThings to fire a push/text whenever a camera detects motion. I can even make it happen only when I am Away.

Can someone else reproduce my solution??

TLDR Set Arlo app mode to armed and modify it as you see fit. Use SmartThings to turn on and off cameras and to handle notifications.