Smartthings ikea bulbs

Hi there,
I have added several ikea bulbs to smartthings and they do work but there is a one to two seconds delay to turn them on and off.
Is there a better specific edge driver that handles this better?
They are running on local automations but they feel worse than my worst cloud automation ever did.
Turning on 4 bulbs at once via automations all bulbs doesnt turn on after 1-2 seconds delay but rather they turn on one after another after the delay.

any advice?

1 Like

@Dick_Karlsson what you’re seeing is known as the “popcorn effect”. It’s worth searching that term on the forums for more details than I can provide. I believe it’s to do with the way ST sends out the zigbee signal in a way that won’t overload the network. I had the same problem when I changed my Hue connection from cloud to local thinking it would speed up response, but it had the opposite effect when using automations in ST. The solution was an edge drive made by @blueyetisoftware which is specific to Hue and executes scenes within Hue rather than ST. From memory there isn’t a generic solution. Are you using an Ikea hub or bulbs connected directly to ST? If a hub, can you use the Ikea ecosystem to execute scenes instead of ST?


I’m using the Edge driver “Zigbee Light Multifunction Mc” for all of my smart bulbs (Ikea and Sengled).

I’m not seeing any delay when using that driver.

Hi, I have the same driver on all my ikea lights, is there any setting you have to do? Because I dont really see any difference between this one and standard edge. I dont see the benefit or understand it.

Thank you

1 Like

Thanks for your reply, i will have to look it up.
I dont have a ikea hub just smartthings but this is not really acceptable on any level…

My local automations is overall slower than any of my previous webcore piston automations, i dont mind for other things really but lights need to be instant otherwise it just feels wierd.

Hi @Dick_Karlsson

When you change from dth to edge drivers, uninstalling and reinstalling several devices the zigbee or zwave mesh is affected, interrupting established routes and that now have to be restored in the most efficient way.
This can take hours or days, zigbee faster than zwave, in my opinion.

You can try to reboot or turn off the hub for about 10 minutes, other users think at least 20 minutes. For me, 10 minutes always worked for me to rebuild the zigbee mesh.

It also depends on the number of drivers and devices running edge. The hub’s hardware resources have limits and we don’t yet know what those limits really are for optimal local execution performance.

Thank you for your reply, I factory restored the hub, installed a few drivers and paired my zigbee devices, around 50 devices - few virtual ones but mostly ikea lights then some ikea outlets, motion sensors and buttons and 5 temperature aqara sensors.
I would think my usage is about normal.
This is quite a bad step if this is normal across smartthings users
And I even notice smartthings automations that fail to run even basic ones.

I have something similar.
a v3 hub with 55 zigbee and virtuals plus 5 zwave working and 19 drivers installed and everything works pretty fast for me.

It already tells me that the memory is pretty full, but it still lets me install new devices

What could the issue be for me? Can you give me a wild guess?
I even tried to change zigbee channel to 25 but then my zigbee aqara temperature sensors stopped updating temperature for some wierd reason. Changed to 20 now.

It shouldnt overlap wifi 2.4ghz band too much but its like every action sent out is a 2 step thing like.
Send out power on to light, light sends im turned on to hub, hub then powers on the next one and so on.

I cant turn two devices on at the same time no matter what it is, via automation or scene.
Cant say it was this bad when I had webcore in use…

Well, I’ve been testing with routines of various lights and I notice them slower than normal. especially the zwave
I don’t know if it has to do with new firmware 46.4

Im sorry to hear youre also experiencing delays but somehow im glad im not alone in this.

Is it a waiting game now or should I / we contact support?
Its not really usable like this since automations should be improved on local not become 2 times worse than before.

Bwst regards

1 Like

I don’t know if other users are noticing something different
@nayelyz Have you received any report of slowness in the routines with several simultaneous devices?

Are they just slow or they don’t execute completely?
If the first, I heard about one but I redirect them to Customer Support, I don’t know the type of device or else.
Hi, @Drknght4. Did you get any response from the team about your case? Is it similar to the one mentioned by @Dick_Karlsson?

It looks slow, they turn on and off one by one with local routines
When the same thing is done, but with a scene, which is not local, it is much slower and sometimes not all the actions have been executed or very late, 5 or more seconds later.

Especially the zwave devices are very slow, but it may be because of my zwave network, which only has 5 devices

All of my automations are slow, I really do mean all of them. Since I started using edge on my router instead of dth and webcore everything about this hub has been a really bad experience.

Ive had a few select routines that didnt execute completely (basic ones)

I didn’t get a chance to report yet. Doing it today. I’ll keep you posted. Some of my sunset/sunrise routines didn’t execute today

1 Like

To who should I report slow inea devices to? Can anyone give me a link? Last time I reported something I was asked to go to the forums and ask, I found that very odd.

Presence has stopped working now aswell all of a sudden, this hub is starting to get to me.

Can someone help me out here with tips / ideas of what can be the cause of this? And perhaps where to turn for help?

If this continues this hub is worthless and im forced to leave it be.

Thanks in advance

Is this the future of smartthings? :thinking: does anyone have any idea? :no_mouth:

What driver are you using with your Ikea bulbs?

What type of phone do you use for presence? In the app permissions, I’ve found that you have to allow the smartthing application access to your location at all time in order for presence detection to work properly.