Smartthings Hub Wifi v3 Mesh - Green Solid/Green Blinking alternating light

Help me out community! I have two Smarthub Wifi units that were working fine until last night. Around midnight they went offline. Since then they alternate between solid green light and blinking green light. I tried factory resetting them and they dont even respond to that. Occasionally I can get them to go to solid magenta light, but as soon as I try to reset or plug them into a LAN, they go back to the solid green/blinking green state. Funny part is, BOTH main unit that was connected to router AND satellite unit that was wifi to main unit went into this state the same night! Smells like an update gone bad to me, as I can not find anything about that state online.

Anyone else run into this? If so, how did you get out of it?

Strange, I think blinking green means the hub side is in pairing mode.

Hey there!

Thank you for reaching out for assistance with your ST Wifi Hubs(With Plume).

The LED indications on the ST Wifi hub would mean the following:
Solid Green - Power on, connected
Flashes green - Booting/resetting the system
Flashes green and red - Ready for initial setup/Connect
Flashes red - Function error during setup, network not available, or overheating
Solid magenta - download mode (manual update)

If you’re experiencing the device switching between Powered On and Attempting the boot-up process, I’d recommend trying a Reboot of the hub.

Here are the steps:
Rebooting the Wi-Fi Hub:
There are two ways to reboot the Hub: through the SmartThings app and by unplugging the power cord.
To reboot the Wi-Fi Hub through the SmartThings app, the Hub would need to be online so this option would not work for your case. You would instead need to hard reboot the Hub, unplug the power cord for a few seconds, then plug it back in to trigger the hard reboot.

If the symptom persists, I would recommend creating a Support ticket so we can look into your concerns further.

You can reach out directly to a support team in your area using the below information:
US: 1-866-813-2404

I hope this message finds you well!


Yeah, something is not right with these two hubs. Its like they went to update and didn’t finish, and they are in this state of “factory mode” limbo. Its crazy that this happened to both of them at the same time. If I ever get them working again, I will definitely disable auto-update if possible.

Hello SamsungZell,

Unfortunately this reply did not help, as it is basic troubleshooting steps that I have already taken. I am beyond that, this is a very specific problem that doesn’t appear to be listed on the Support Group nor Tier I had any idea how to resolve. I have created a Support Ticket with Samsung and am waiting for Tier II to call me back.

I also think 2-5 business days is too long for someone to wait for Tier II support. My entire home automation was built around this hub and now I am completely down. Not a very good customer experience.

It’s not possible on the end-user side as far as I know to disable auto-updates. Additionally, I don’t even know if they’re supporting these still.

I have quite a few instances of these devices deployed, and I also had some funny business occur in the past 24hrs. Nothing of this severity, but I’ve had a couple drop offline requiring power cycles, and I also can no longer see the mesh connection quality in the Home Pass application.

In past weeks, I’ve had trouble with satellite hubs dropping from the main hub and not reconnecting without a power cycle as well.

Moral of the story, this tech is very cloud dependent, and very sensitive. If you need something you can count on, this ain’t it. A shame since they do perform well when they’re working correctly.

Thanks coalshark, I am starting to believe the same. I had great success early on, and they seem to operate very nicely. I did get the main and satellite unit dropping off every now and then, but it was always corrected with a power cycle. I’d say I got that once every month or so. Nuisance, but bearable for home use.

And I have worked in electronics manufacturing in the past which is why I believe this is an auto-update gone wrong and a set back to brick, pre-programmed, factory mode. The fact that both of them had this happen at the same time just confirms my suspicion.

I hope Samsung makes this right, I will let you know what happens.

I am happy to see that the issue have been solved. Keep sharing this type of content.

Thanks again,


Mabelle is has not been resolved. Still a problem. Still have two bricks sitting here. Still down.