Smartthings Hub v3 Fails to Add New Devices After the First 64 Added Successfully

Z-Wave network consisting of ST Hub V3, ~45 Bali/Somfy shades, ~20 Leviton switches and dimmers, and about 30 other switch/outlets/etc were all installed around 2019. Due to the supported driver changes this past July, it was easier to reset everything and start a new install. The problem I’m having today is identical to the problems I experienced in 2019 with the initial implementation.

In short, after successfully adding a little over 60 devices to the hub, via the current iPhone app, I can no longer add new devices.

The longer explanation -

The first 60 or so devices add just as expected, whether I add using the generic “Scan for Nearby Devices” or I select “Partner Devices” and find the exact item I’m adding. The issue started after device 64 or so - I would set the hub to add a device, put the actual device in “Join/Add” mode, and the device will acknowledge that it has been added to the network. The ST App never shows the device being added. I can immediately go through the process to “Exclude” that device and both the device and the ST App will reflect a successful exclusion. The App actually shows “Device Deleted”.

Further, in 2019, I was able to get past this issue via the previous web interface. There was an option to manually add a device, assign it’s z-wave Network ID, driver, etc. I could locate the last device successfully added, increment its Network ID by “1”, and create a new device with that Network ID. I would occasionally have to hunt around with other Network ID’s in the range but I could always find the new device, it would be added successfully, and everything worked perfectly for 4+ years.

Today, I’m going through the same process but with one failure - the ST website no longer has an option to add a device manually. As such, I’m left with no option to find the device that thinks it’s added, has a Network ID, but Smartthings isn’t registering it.

Any suggestions are welcome.

To help in heading off the standard trouble-shooting questions:

  • Before starting the rebuild last week, I hard reset the hub and created a new Smartthings account so as to be starting entirely fresh.
  • I hard reset every device before adding it to the network.
  • the 64 devices I have successfully re-added are all working perfectly.
  • The Hub is running the latest firmware available.
  • I have repeaters scattered throughout the house. I tried with and without these powered up.
  • I have tested this with the hub 30 feet away all the way down to <1 ft away. Absolutely no difference.
  • I have reproduced this issue with 10 separate shades. After the 64th device, all of them react as though they are successfully joined to the network but Smartthings does not reflect the device anywhere in the app or website. Both the device and the app will reflect a successful exclusion, when I run that process.

I appreciate any ideas this group might have.

1 Like
  • iOS 1.70.06 update was released yesterday so don’t know if you got that version yet
  • you’ve checked that there are no devices in the “No Room Assigned” group?
  • led on hub changes color to Blinking Green when adding device?
  • have you tried: Add device > Partner devices > Z-Wave?

Thank you for the reply JKP!

  • iOS 1.70.06 update was released yesterday so don’t know if you got that version yet
    Reply: I wasn’t aware of the update. I updated just now. Everything stated above reacts the same.

  • you’ve checked that there are no devices in the “No Room Assigned” group?
    Reply: Yes. No unassigned devices. Further, the device list on the website doesn’t list it nor does the total device count go up.

  • led on hub changes color to Blinking Green when adding device?
    Reply: Yes

  • have you tried: Add device > Partner devices > Z-Wave?
    Reply: I had not tried this exact option until just now. I selected the option to add Z-Wave, chose to skip the QR code, and it starts searching. At that time, I put the shade in “Add” mode and it confirms the addition within 5 seconds. The app continues to scan until it times out (about 30 seconds I would guess), and then ask “What kind of device do you want to add?” I select “Generic Z-Wave Device” and it starts searching. The shade immediately acknowledges being added to the network. After about 1+ of the app searching, it shows a screen stating “Something went wrong”, “It looks like we couldn’t connect. Try again or reset the device.”. I closed that window and went to exclude that device. Both the shade and app confirmed the exclusion.

Have you tried pairing the devices next to your hub? Since the switch to Edge I have had to do this with many devices. I might not help but is something to try.

I have tested this with the hub 30 feet away all the way down to <1 ft away. Absolutely no difference.

I’m sure that’s very frustrating. :disappointed_relieved: What’s the total number of devices on your account, including virtual devices? There has from time to time been a limit of 200 devices per location, but I haven’t heard of a limit on zwave devices specifically.

There is a hard limit of 64 child Zigbee devices per hub, but again, not zwave. :thinking:

Have you opened an official support ticket yet? They can see things from their side that we as customers can’t, so maybe they can find something.

Thank you for the reply JDRoberts!

Currently, I have 1 hub, 64 z-wave devices connected, and zero virtual devices.

I do have a ticket open and anxiously awaiting a reply.

1 Like

For anyone interested, this is a thread from 2019. Many people experiencing exactly the same problem I was then and now.

This is where I found the “manual Add” workaround that no longer exists in the ST management website.

That one wasn’t quite the same problem, but it had the same outcome: a zwave device added to the hub but not showing up in the app or, at that time, the IDE.

Definitely odd. :thinking:

Tagging @cbaumler

Thanks for bringing this to my attention. Sounds very frustrating. @MChad I can have the team look into this. It would be very helpful if you could enable account data access and DM me your Hub ID. Also, DMing me specific details around the failing device would speed up the investigation. For example, the approximate timestamp when you tried to add a device and failed and/or the network ID of the device in question.

Enabling Account Data Access:

  1. Go to SmartThings Web ( )
  2. Log in to your Samsung Account
  3. Select the Menu (⋮) and choose Settings
  4. Toggle on Account Data Access
  5. Select the time period and choose Confirm
1 Like


It’s is actually exactly the same problem. My devices, in 2019 and today, add to the network; however, neither the app nor the ST Website reflect the add. In 2019, I could look at the logs and see the new Network ID added, I could take that ID and manually add a new device via the ST Website, and the device would work perfectly. The only difference today is that the website has changed and no longer allows the manual addition of devices nor can I see the logs to prove the new Network ID found.

Thank you, Chris!

Account Data Access has been enabled since the case was opened about 2 days ago. I will DM the rest.

I mentioned it was different from the original problem reported there, because that one didn’t seem to have to do with the number of devices already on the account. But in any case, hopefully Chris’ team will be able to help. Good luck— let us know how it goes. :four_leaf_clover:

All good. Yes, in 2019, the problem didn’t start until around 50-60 devices had been added.

I have to think this is a timing issue somewhere. I’ll update the thread if we find an answer.


1 Like

Chris - A bit of an update:

I successfully added 2 additional shades last weekend. Both required a number of include/exclude cycles to get them to add properly. Further, I had to use slightly different processes between the two, although they are identical units. But, in the end, they did add.

Another interesting point to go along with my theory that the network is actually adding the device but failing to update any of the user interfaces: I have Bali Advanced remotes, which are used to control the shades. It adds to the network as a z-wave device. Through that process, it will reflect the assigned z-wave Network ID it receives. I had to try multiple include/exclude cycles to finally get it added; however, each time through the process it would show me the Network ID assigned - even thought the ST App and Website did not reflect a new device.


Thanks for the additional info. We’ll take this into consideration in our investigation. Hopefully, we’ll have an update for you soon.

1 Like