Can't add any device to my new Smart Things hub


(Nick) #1

I have been trying to add my existing ZWave devices to a brand new Smart Things hub for days and it is not working. I am about to return it unless I can get something functioning soon.

I have been trying to add Intermatic HomeSettings HA03 and Intermatic HA05 devices.

When I try to add a device it just spins and never finds anything even though I have tried pushing the programming button a hundred times. I have also tried the “General Device Exclusion” but it just spins, again while pushing the programming button.

I have even wiped my device and started from scratch, tried joining/leaving z-wave network (which just says failed). I am really dead in the water and nothing appears to do anything.

The online IDE says my zwave is “Protocol Version: 3.83” and “State: Functional” not much else listed there except Ids.

In the event log the only things I see that seems weird was:
Err 103: ZW include failed not primary cntlr

But I have no clue what to do about that.

Can anyone provide any help.


(Rick S) #2

Hey Nick,

Were these devices part of a previous setup or are they all brand new?

If not new, do you have the old hub that you could stand back up and exclude them first? A device can only be part of one network at a time IIRC

Beyond that, I am lost as well

Good luck
Rick


(Bob) #3

As Rick has said but perhaps if you factory reset the devices so that they ‘know nothing’ of any pre-existing network, they may pair then.


(Nick) #4

So both :slight_smile:
The Intermatic HA03 was part of an existing network (I have a MicasaVerde) but I removed it already. If there is a better way to remove it let me know (I treid from the UI and by pushing the minus and then the programming button on the device).

That being said the Intermatic HA05 was NOT part of an existing network it was a device i got in a huge bundle and never used it. I wanted to make sure it wasn’t Only devices that used to be connected to my old gateway having issues but I still can not pair that either.

Other things in the log (probably not relevant but I am desperate)
devicetype:04, mac:14DAE9089A40, networkAddress:C0A70085, deviceAddress:0B35, stringCount:04, ssdpPath:/upnphost/udhisapi.dll?content=uuid:abafaf94-32f1-4b3c-aa1e-99d1833b98f3, ssdpUSN:uuid:abafaf94-32f1-4b3c-aa1e-99d1833b98f3::urn:schemas-upnp-org:device:MediaRenderer:1, ssdpTerm:urn:schemas-upnp-org:device:MediaRenderer:1, ssdpNTS:

devicetype:04, mac:000420F64A18, networkAddress:C0A7003B, deviceAddress:1F98, stringCount:04, ssdpPath:/description, ssdpUSN:uuid:4dc2fb37-354b-4854-befa-9fadd237af81::urn:myharmony-com:device:harmony:1, ssdpTerm:urn:myharmony-com:device:harmony:1, ssdpNTS:

Also Thank you so much for the responses both of you!!! I really appreciate it.

I have tried to factory reset devices but they just have a programming button… if anyone has a clue what else I could try I would absolutely do it.


(Bob) #5

I’m afraid I have no idea or experience of those devices.
Were the devices connected directly to your old hub (ST) or were they via a bespoke hub?
Are you using a V2 hub and your old one was also a V2?
Have you actually had these devices connected to an ST hub?
Sorry for the questions but I’m just trying to get a handle on the situation.


(Nick) #6

No need to appologize at all! I left verbose comments because I wasn’t sure what all information people would need :slight_smile:

The HA03 was connected I believe directly to my MiCasaVerde (which is another Z-wave hub http://getvera.com/controllers/veralite/)
But again the HA05 should have never been connected to any other Z-wave network I just opened the box today.

I don’t actually know how to answer/check the V2 question sorry :frowning: if there is anything I can look up or check let me know!

I have never had any of these devices connect to smart things hub (I just bought this one last week and sadly have been fighting with these problems ever since).


(Bob) #7

I suppose that means that we need to find out if these devices will connect directly to the ST hub.
If not does the Intermatic hub have IFTTT connectivity. You may be able to interact with the ST hub that way.

Anyone else out there have these devices.


(Ray) #8

You can exclude the device and bring it back to default state by having the ST hub in exclusion mode in the app and press the on/off button on the Intermatic.



(Nick) #9

I assumed it would connect because I found this support page and was following its directions to add the devices.

And that image is literally the device I am using lol

Again Thanks a ton for the help!


(Bob) #10

In that case if they are factory reset I would have thought they would connect OK.


(Bob) #11

Did you try this?

To reset the Intermatic device

If the Intermatic device was not detected, you may need to reset the device through a Z-Wave exclusion before it can successfully connect with the SmartThings Hub. To do so in the SmartThings mobile app:

Tap the menu (Android) / More (iOS)
Tap the Hub
Tap Z-Wave Utilities
Tap General Device Exclusion
When prompted, press and release the programming button
After the app indicates that the device was successfully removed from SmartThings, follow the first set of instructions above to connect the Intermatic device.


(Nick) #12

So I tried the General Device Exlcusion things about a hundred times and it never worked… BUT!!! I figured something out and got 1 device to add.

The Smart Things hub somehow auto connected to my Vera (I guess before I unplugged it). So not sure what was going on but SmartThings was super confused. Once I was able to get SmartThings off that network. I was able to do the exclusion and then was able to add the device.

Also now I no longer have the “Join/Leave Z-Wave network” button… so for future if anyone has that button then they might be connected to another Z-Wave network and need to get off before they can add things. I certainly don’t know how I got into that state… but I made some progress so wish me luck adding more devices :slight_smile:

Also thanks again for everyone who pitched in and tried to help I really appreciate it.


#13

Hi, I am experiencing the same issue and receiving the same message when I try to add ANY Z-Wave Device (no issues with Zigbee, I have ~ 30 Zigbee working devices). I don’t have another HUB, Vera or similar to try and remove my Smartthings HUB from their Z-Wave Network (but I do have the “Join/Leave Z-Wave network” button in the developer website and a “remove hub from Z-Wave Network” into the app). Tried using it but it wants me to put the “primary Z-Wave controller into Exclude or remove mode” in order to remove my Smartthings Hub from the network, which I can’t do since I have no idea were/when/how my Smartthings Hub got associated with this other Z-Wave Network (came this way when I bought it).

Any Suggestions short of returning it? I would like to avoid to factory reset the Hub (not sure it would help and also have spent a lot of time adding devices, setting rules, integrations etc…)
Can Samsung support wipe the “Z-Wave” section of the device without touching the rest?
thanks