Can't add any new devices

Hello. New user of SmartThings, and new to this excellent Forum.

I have the three unit SmartThings Hub and Mesh Wifi system.

Problem: I cannot successfully add any devices. I am starting with supported devices namely Leviton Z wave wall switches, Jasco Z wave switches, Intermatic modules etc. They are not automatically found, nor can I successfully add them manually.

I suspect I am doing something wrong at a very basic level.

My Arlo camera hub installed easily and automatically, but it is connected directly to my router.

I appreciate any assistance.

Thank you.

have you tried a z-wave exclusion? Is the hub flashing a green LED on the front when you are in pairing mode?

1 Like

No flashing on the hub.

You mean pairing mode on the switch?

Following the instructions on SmartThings, I am not even sure I am in pairing mode. (I’ll limit this to the Leviton switches for now, for simplicity).

I believe all hubs are supposed to flash when on zwave pairing mode. Are you choosing the specific device when adding in the app?

Yes. Have tried all the different Leviton options just to be thorough.

So the Hub’s green light should flash as soon as I select “add a new device”?

Additionally, just to be clear I am looking at the remote hub closest to the switch (~10’), not the hub hooked up directly to my router.


If you have multiple hubs you may want to check that you’re putting the correct hub in pairing mode from your ST app (I would say use the ST Classic app, select your location and then try to add a device to it). Like Jimmy said, when in pairing mode it should start flashing the light

1 Like

I am not offered the choice of selecting a Hub when adding a device. I know all the support literature indicates that step, but it never comes up.

So in Classic Mode, I am given that Option?

Classic app is a separate download?

Yes to both questions.

In the classic app you can select your location (and consequently the hub in that location).

1 Like

Using Classic now.

Sorry, I don’t see anywhere to specify which Hub I want to connect to??

Click the Last tab, bottom right. Then on top you can select which “Location” you want to use. You should see all your locations here. Each location should have one hub. If you don’t see it then the hubs weren’t registered to your ID properly.

Once your location is selected you can then go to the Home/Things page and tap on + to add a new device.

I can see my Hubs in the other version, it reports them by name, and says “3 hubs working great”.

The last tab on the bottom right in Classic is “Marketplace”

Oh, I think you’re using an Android device. I should clarified my instructions were for an iOS device.

In the Android you should have an option to select your Locaiton see this:

Yes Android phone.

I don’t see the option you are referring to.

I am installing app on my iPad now.

One moment please. Thank you.

OK on iOS now.

Tapped the three lines at bottom right: Resulting menu does not offer a “Locations” option

To add a Location the app is requesting a code.

Is this what I want to do?

What code?

He only has one hub. It’s the mesh WiFi system, so one unit is the hub and other two repeaters. The main unit should flash when in pairing mode.

Oh OK.

So just the Hub connected to the router should flash?

Confirming: YES that Hub does flash, the Hub closest to the switches I am trying to add does not.

I believe those are repeaters and not really a “hub”.

Ideally your device should be within about 10ft of the hub while pairing.

How do I do that with an in wall switch?

A VERY long cat 5 cable?

I am migrating from HomeSeer, which used a detachable USB drive to add fixed, remote devices…like wall switches.

It is disappointing if SmartThings didn’t think of that.

What about importing my existing HomeSeer ZWave network? I believe I saw an option to do that in SmartThings.

If the switch was on Homeseer, you need to exclude it first. Then you can pair it. you can exclude via Homeseer or SmartThings. Https:// has help articles on exclusion.