Smartthings Hub v2 failed (flashing red) after disconnecting power

I need to clean the area where my Hub is located. So I unplugged the Hub for about 15 min. After I plug the hub back in, it has been giving me this slow blinking red ever since and my Hub is offline.

I have tried unplugging the power, remove the batteries for a minute, put in new batteries and reconnect power, even connect to a different ethernet port. The light still blinks red. What can I do to fix it?

I will give the 30min wait a try but I don’t think the procedure is accurate. When the hub’s ethernet is connected, it should blink BLUE. (I have the v2 hub). In my case, the light for Ethernet jack is not even blinking. I think the Hub didn’t really boot up.

Samsung Connect Home (mesh WiFi with SmartThings included) is not the same thing as Samsung SmartThings Hub V2.

Red blinking is a power issue.

I missed that. Thanks @HalD . I’ll pull the post. :flushed:

1 Like

Even tried hard reset with the push pin when connecting power. Still no luck. I think it is bricked. I am in disbelieve. It is not like there is a shutdown button. I would think that I can unplug the hub anytime.

Unplugging and pulling batteries is one of the most common suggestions from support as far as I’ve seen. It’s the only way to reboot the V2 hub.

Are you sure the new batteries are good and installed correctly? I’d start with just batteries, see if it boots. Then plug in power supply.

Do you have a multimeter or anything to test that the power supply is putting out the correct voltage?

Indeed! I tried another set of batteries (3rd set, brand new) and this time the Hub turned Green. I measured the power supply and it reads 5.18v but it is not under any load. There is definitely something fishy about the power. I need to find another 5V/2A power supply to test it out.

1 Like

It is confirmed. The issue is with the power supply. I most likely have this issue for a long time. The included, white, power supply must have failed but it is supplying just enough current to keep the hub running when the batteries are in. I swapped another 5V power supply and I can run the hub without backup batteries.