SmartThings Hub show Z-Wave Not Functional

I bought a SmartThings Hub to connect to my Schlage Connect Be469NX lock. I tried multiple times last night to link the two. I logged in to the ide and see it shows the Z-Wave as not functional. Is there something I can do to make it functional or do I need to return the hub?

Try to reboot the hub. If that’s doesn’t work try to reset it otherwise exchange it.

Also keep the lock within 5ft if the hub after rebooting it before trying to pair it. You may exclude the lock before pairing it.

After pairing consider adding a buffering repeater between the lock and the hub since Schlage locks can be finicky with the mesh. See this for more details: FAQ: why would I need another beaming repeater if my zwave lock is already close to my hub?

1 Like

Thanks for the tips. I have already rebooted and reset the hub. I have enabled Z-Wave on the ide tools. I am currently connected to a netgear wifi repeater, could that be a problem? I think I might have a bad hub.

Did you ever get this working? I have this lock tied to another automation hub and wanting to switch it to SmartThings.