Smartthings Hub made in China will not validate s/n

My problem is that I am unable to connect/install my Smartthings Hub. It is a wi-fi (2018) Hub that someone gave to me as a gift. When I get to the point in the setup process where I either do a scan of the qr code or enter the Hub’s serial number I get a message that it can’t be validated. I tried both the qr code and s/n, with and without wi-fi and Ethernet cable to my router.

I spent about 1 1/2 hours on the phone with Samsung Smartthings support and exchanged multiple emails. After doing some checking the person on the phone said that since the unit was made in China and not the US they couldn’t validate the s/n and couldn’t suggest anything else. After checking the box the Hub came in I sent them an email stating that yes the unit was made in China by SAMJIN Inc but it was then imported by Samsung Electronics, 85 Challenger Road, Ridgefield Park, NJ. While their logic may sound feasible that since the unit was made in China they could not validate the s/n, but given it was imported by Samsung’s US facility I wouldn’t expect the problem to be the original manufacturing location. Haven’t received a response to my email that it doesn’t make sense not to validate a unit they imported.

Hope someone can help with suggestions as to what I should try next. Can anyone suggest how I can get this Hub connected/registered? Since it was a gift taking it back to the store it was purchased at is a nonstarter.

Thanks in advance for any help you can provide.

lol what?! Samjin manufactures all of the V3 hubs. What country are you in?



Samjin produces the Hub 2018 in China. Sounds like someone from support is confused, I’ll see what I can do.


You are using the SmartThings app, not SmartThings Classic app right? What are the LEDS on the Hub doing?

Any chance they used it before giving it to you? :slight_smile:

I’m in the US


Any chance they used it before giving it to you?

The box was sealed so not previously use. Person that gave it to me is a good family friend so I am 99.99% not used.

1 Like

Brad ST

I am using the Smartthings App, not the Smartthings Classic App. The LEDS are blinking red and green.

One other thing, I’m using the Smartthings App via an Android Emulator on my PC. My phone is a 5c with iOS 10.3. Since I need a device with iOS 11.0 or later I went the route of the emulator

Well that is probably your problem. Your emulator isn’t likely to be able to connect to the Hub.


Brad ST

I was afraid the emulator might be the issue but without a phone with iOS 11.0 or later didn’t have much choice but to try it. Maybe I’ll try a different emulator (using Bluestacks in case you are wondering) or wait till I find someone that is willing to lend me their phone that would connect the Hub

You could use a cheap Android phone from a big box store. I haven’t looked at them myself but I have seen many posts on the forums stating they can be had for $15 these days.

Just a thought …

I’ve used VirtualBox and Android-x86 with some success on other projects if you need a recommendation. Some links that may help if you decide to go that route:


Good idea, something I hadn’t thought of as a possible workaround / solution



Thanks, appreciate the suggestion.

In the past, multiple community members have reported problems using the smartthings app if their phone did not have an active data plan. I don’t know if that still true, but if it is, it means not only would you have to buy the phone, you would have to activate it for long enough to get everything set up.


Ugh. Why does everything have to be so difficult?

Hadn’t thought about the data plan requirement. Thanks much for pointing that out.

I’m thinking about that again, and now I’m thinking that may only apply if you’re trying to set up Geo presence.

The other issue that does come up a lot, though, is exactly which browser you are using. Many people with Huawei phones, for example, have been unable to use the apps because the browser is incompatible.

Can you use chrome with your simulator? That seems to have the best results.

I tried to reproduce with BlueStacks.

The issue seems to be the inability of the emulator to connect to the Hub’s SoftAP.



The browser I am using is Chrome.

1 Like