SmartThings extreme delay

My system has become unusably slow.
I’m experiencing 15-minute delays even with very nearby devices.
This is a new issue and seems to have started overnight when I wasn’t changing anything.
For example, I have two new Jasco outlets within arm’s reach of my hub. If I go to devices and chose to switch either of those on or off nothing happens. Sometimes I get a message about network error if I exit the app and try again, I don’t get that message. If I wait long enough (15 minutes or so) my change will be applied.
I have about 80 physical devices, all Z-Wave, mostly Z-Wave Plus.
This network used to be reasonably stable before switching to SmartThings.
I’ve run a Z-Wave repair which tends to fix slow response, although this is the worst I’ve ever seen.
A hub reboot has also been tried.
I have a solid green LED on the hub.
My gut feeling is that my hub is running at a high CPU load but I don’t know how to get basic troubleshooting statistics on this hub.
Are there any troubleshooting tools for SmartThings?
Or are educated guesses the best one can do?



There are some basic things you can try before you contact support.
Turn hub off for 30 minutes and power on again.

Reboot cable / fibre.
Reboot router.
Reboot wi-fi / mesh.

Contact support from the smartthings app, menu, contact us, Call us or Error reports.

After I sent this I went outside and did some chores. When I returned about 90 minutes later it seems to be much better.
I did remove a couple edge drivers, a GE/jasco driver that doesn’t seem to be compatible with any of my Enbrighten devices, and one other which I had recently installed and wasn’t using may have been related. At this point I don’t know what might have been going on or what, other than patience, resolved my issue.
Time will tell I guess.
Thanks for your suggestions. I’ll keep them in mind if it acts up again.


How many Edge drivers are installed on your hub?

I also have been having delay issues, sometimes up to 5 minutes, (which coincidentally is the default reporting time for the devices).

I got deep into troubleshooting with SmartThings and a few related excerpts follow. Keep in mind that I disabled my SharpTools rules and created duplicate SmartThings Routines because initally they said the issue was with SharpTools.

The information was captured using SmartThings CLI:

Hi Nayely-

I may have captured it.

I ran the CLI and opened the laundry room door a8f50a26-b1aa-40c9-b106-10bfaa483a51 which is in the SmartThings routine “Basement Stairway Lights Turn on”. The lights did not turn on so I left the door open. After about a five minute delay, Basement Stairway Lights e9bf2fde-393e-4f70-9a8f-635466228b13 turned on.

The time was around 7:59 PM or 8:00 PM Eastern Time. Interestingly, the CLI program did not seem to scroll by when this was happening. I looked through the data but could not find a time stamp around the 7:59 PM time. I could just be missing it. I will paste the data at the bottom of this email.

Hi, Kevin.
This is really great evidence, thank you for collecting the info, I already created the report for the engineering team.
In this case, we would need to see why the driver got the event after 5 minutes or so, if it was due to something in the hub, or if the message was actually received until then from the device which I don’t know what can cause it.

Hi Kevin

Nayely will be off for some time, so I am following your case, reading your thread with Nayely I can identify two errors one related to a delay in events and another related to 2 sensors.

1 Case (Events delay): the case is being investigated by the team, as soon as I have updates I will inform you

2 Case (2 sensors): please, Can you explain the issue with these devices? for the last mail, these devices were removed from SmartThings,

Note: if I have missed something please let me know

NOTE: I removed 2 OLD devices that were not being used and replied back to their Engineering with that information.

Hi Kevin
I’m happy to hear that, so I will be pending of the investigation for your first case (Events delay)


Hi Kevin

Unfortunately, we can’t see a delay in the logs in the previous mail you commented that the door was opened around october 4th at 7:59 PM or 8:00, in the locos we can see the following:

1- the device sent the open event to the hub at 2023-10-05T00:05:06.131509479+00:00 UTC
2- the event turns on the light at 2023-10-05T00:05:06.624864145+00:00 UTC

So we can’t see the delay based on the logs, but will still investigate why the device is sending the event 5 minutes after


Hi Kevin

I understand, from our side, we can only discard that as a problem of SmartThings Hub or the Driver, that does not mean that the devices are bad but the reason for the delay is not caused by SmartThings. As you mentioned the problems are generated randomly, in my opinion, something wrong happened between the devices and the hub. they are out of our scope.

I can recommend checking the following :
- Sometimes users have problems with Zigbee and Wi-Fi channels, you can read more here
- Try to re-add the devices on SmartThings
- Check if, after some steps or using a specific scenario, you can reproduce the issue

but there are only recommendations

So basically they gave up at this point!

The delays still persist!!!

ADDITIONALLY: I’ve recently been having unrelated issues with all of my Zooz motion sensors getting STUCK on ACTIVE. They have worked fine for a long time. Working with Zooz Support, I bought a new one and swapped out 1 of them because they initially said the device was bad. Same thing happened. So then I got this reply back from Zooz Support:

Hi Kevin,

We’re currently working with the driver developer and SmartThings support to resolve the problem. It’s not clear what’s causing it other than some type of recent platform change on SmartThings. We’re trying to find the source as quickly as possible and will notify as soon as we have a fix. Thank you for your patience!


Zooz Support Team

EDIT: So now I’m wondering if this “recent platform change” is the cause of these other issues…???

Very Interesting!

Had one case of a “stuck” Zooz motion sensor here, as well, just last week. I wrote it off to a “lost message” from the device not making it to the appropriate hub driver. Everything was still working and simply walking into the room started a new motion cycle and all became well.

This behavior isn’t new to me: it happened in the past with other devices, including a (different brand) motion sensor. In 2017 one of three door sensors reported door “open” at our second home 1500 miles–I ended up writing a special DTH to see if the door was okay. Here’s what I ended up doing to prove the door was closed, if you’re interested…

1 Like

I have about 80 physical devices. Everything is Z-Wave.

you may have misread my question - how many Edge drivers (not number of devices) have you installed on your hub? :slight_smile:

are many of your devices GE? what drivers are being used for them… ST stock drivers or community developed?

Notes about my setup.
The system in question is at my Cabin about 200 miles from my home.
There are 4 buildings.
One of the buildings, containing my hub, is somewhat centrally located, roughly 50 feet from two of the buildings and maybe 30 feet from the other.
I have several devices located outside specifically to act as repeaters to improve resiliency of the mesh.
For years I was running on Axial Control using an Aeotec Z-Stick Gen 5.
This Labor Day I started making the switch to SmartThings and the process has been a lot of work.
I ended up replacing a number of very old non-plus Z-Wave devices with new Z-Wave Plus devices.
As a result the network should be much better than before.
I experienced plenty of delays and devices which would just disappear from the Z-Stick before, but nothing like I experienced today.
I’m back at home now and I can tell that things are still working better than they were for about 4 hours this morning.
To answer JKPs last post there are three Edge drivers which I have added.
and TAustin Shared Projects for a few virtual devices.

Many of the devices are GE/Jasco/Enbrighten.
I had installed the GE/Jasco Enbrighten Edge driver but I couldn’t get any of those devices to show that driver as an option.
So, I deleted it when I was having trouble this morning.
Those devices are and have always been running on the built-in SmartThings drivers.

try these community developed Edge drivers for your GE/Jasco/Enbrighten devices (if you are not currently using them) and see if they work better for you.

Unfortunately, that’s the one I installed Saturday, and removed this morning.
When I would select alternate drivers from any of my Jasco devices there would be none.