SmartThings Edge Developer Beta | Known Issues and Bug Tracking

From the app I can now access the hub drivers and all the channels.
From the cli, I’ll try later, now I can’t

UPDATE: with CLI works fine too


1 Like

Regarding the new beta ‘Zigbee Button’ driver when used with the ‘IKEA On/Off Button’ (two-buttons-battery).

  1. Unlike the DTH there isn’t a button capability in the main component for legacy purposes. That’s fine by me but it does mean that there isn’t anything to display in the dashboard tile other than the battery level. Obviously we have to start somewhere but I think that needs addressing.
  2. Unfortunately the battery level is half what it needs to be. Unsurprisingly I had to change the batteries in both my buttons before installing them so they should really be showing 100% but IKEA is quite enthusiastic about 87%. The driver is reporting 44%. I believe we saw that with other IKEA devices using Edge drivers.
  3. Thank you. Just a pity the IKEA buttons are currently useless because of their battery problem.
1 Like

4 posts were split to a new topic: [ST Edge] Issue with the Z-Wave Switch driver

Please send me over DM the following information:

  • Screen captures of the issue.
    • For 1, the comparison between what you should see and what you actually see in the ST app. What do you mean by "there isn't a button capability for legacy purposes"?
    • About 2, did you check the Hub logs to see the value that was reported by the device? I mean in the reporting messages. It would be useful if you shared the logs when the battery is reported, to see if the value received is correct but is not calculated properly.

I’ve gotten a firmware update to 000.041.00004 and am getting a new variation on the previously reported cosock bug:

Lua: runtime error: [string "runner/src/"]:296: cosock tried to call with no sockets and no timeout. this is a bug, please report it
stack traceback:
	[string "runner/src/"]:296: in field 'run'
	[string "runner/src/"]:743: in method 'run'
	[string "init.lua"]:341: in main chunk

This happens when I try to update an existing driver that utilizes cosock. It repeats over and over infinitely as it keeps trying to restart the driver. The driver uses a TCP socket and has one channel handler.

5 posts were split to a new topic: [ST Edge] Devices stop reporting values after firmware update

A post was split to a new topic: [ST Edge] Issue with HTTP request in Edge drivers

Thank you for sharing this @TAustin. I already shared your comments in the previous report on the issue. Once I receive an update, I’ll share it with you.

1 Like

A post was split to a new topic: Issues changing the default range of a stock capability

New channel invitations aren’t showing in the CLI when running edge:channels:invites. The ones that aren’t showing all have the new URL format of

Thank you, @philh30, this is a good catch.
I could replicate the issue, so, I will report it to the engineering team. In the mean time, I suggest you save the invitationID every time you create one because we can still get its details with the following command:

smartthings edge:channels:invites invitationID

A post was merged into an existing topic: [ST Edge] - Fatal error from socket.http

Will hub firmware 0.41 be released soon?
I’m still having this cosock error with the zigbee edge driver (on my V2 hub firmware 0.40.6).

btw, Happy New Year!

1 Like

The engineering team said it will be released in early January.
Happy new year to you too! :partying_face:


A post was split to a new topic: [ST Edge] Issue with the powerMeter ST library

2 posts were split to a new topic: [ST Edge] Issues with the device preferences

3 posts were split to a new topic: [ST Edge] Issue with the doConfigure lifecycle

A post was merged into an existing topic: Smoke Detector Indicators not working

A post was split to a new topic: [SmartThings Edge] Issue with the switchLevel capability

I have the same but turning the hub off doesn’t solve it.