Smartthings devices unresponsive in alexa app

I already created a ticket for this but I wanted to see if anyone else is having the issue that the Amazon echo will not control any Smartthings devices. I can control all of my Hue that are linked to the echo and not through smartthings. It seems that the connection between Smartthings and the Echo are not linking up. I have tried to delete the app out of smartthings and removed the smartthings skill from the echo and also deleted all the devices and added them back but when I try to control anything it says the device isn’t responding. When I go in to the alexa app it says the same thing that the device is unresponsive.

Everything is working for me.

I think I figured out what the issue is, When I turn the device health on most of my devices are unavailable except a few and those I am able to control with echo. When I turn the device health off I then can control the devices that were unavailable, however they are still unavailable through alexa. So it seems there is something up with the device health in smartthings. Its like the device health is reporting to Alexa even if it is turned off.

I had one device unavailable with Smatthings recently, but the device still worked. I reset the hub (pulled the plug and 1 battery) when it came back on, the device was OK again. You might try the reset.