[SmartThings CLI] Issue with the authentication

After i type the command “.\smartthings edge:drivers:logcat” it takes me to the smartthing page to authorize my account. I click authorize and shows that error.

Try to logging in your IDE Page first.

I was already logged in. I tried to to clear all info in the browser and log in again. Still the same error

Hi @nayelyz

Can you help on this issue with CLI?

1 Like

I tried with chrome, Firefox, windows and even on mac…always the same error

Hi, @Joao_Santos!

Please, try the following first:

  1. Go to this path in the Windows explorer:
  1. Delete all the files included there. This is where the Access Token generated automatically is saved, so this will force a refresh.
  2. Now, execute a command like:
.\smartthings devices

This will show you the authorization page again, click on “authorize” and let me know your results.

Same error message.
It doesnt get to the part where the credentials file is created. So when i acess the first path “%LOCALAPPDATA%@smartthings\cli” it only have a txt file with the error message.

Ok, now, can you enable the logging mode for this command to see if it shows more information than the smartthings file you shared, please?
For example:

SMARTTHINGS_DEBUG=true .\smartthings devices

It doesn’t seems to recognize the command.

oh, do you have the latest version of the CLI?

I think that might be a PowerShell syntax issue in trying to set the environment on the command line. In CMD I usually just do


and then use the CLI normally. Translate that to PowerShell.

1 Like

Yes i have. I´m trying to use it today for the first time.

@orangebucket is right, first, execute this and then the SmartThings command. I use the WSL of Ubuntu so I didn’t notice the syntax is different, sorry.
The first time I received this error, but I executed the command again and it worked correctly:

I’ve tried it before but unfortunately it didn’t work too.
Maybe i did something wrong, could you please walk me through the installation process just to be sure?

Here are the instructions:

I tried to do the same in the PowerShell and it doesn’t work for me either, so, I suggest you use the CMD instead.

I got the same result as before.

Did you execute the set command first as shown in this picture?

Yes and didnt worked.

This was to get the logs shown in the console, so I can report the issue to the corresponding team. Thank you for sharing the picture.
Just to confirm, is the email account you’re logging in to the same one you use in this forum?

Yes its the same account. So theres nothing i could do right now?