SmartThings Button to Unlock Android Device?

I am looking to use the Samsung SmartThings Button as a way to unlock (wake from sleep) an android tablet, is something like that possible?

If not I’d be interested in alternatives if people have them, Flic perhaps?

1 Like

Tagging @joshua_lyon


Any button that supports smartthings should be able to trigger this… through sharptools. The trick will be getting Tasker setup to unlock your device.


I am thinking that it is not really an unlock since I have that disabled, is more of a wake/turn on the screen which should be easier?

It doesn’t change the tools, look into sharptools and tasker to control android devices that you aren’t using as a web kiosk. If you are using it as a web kiosk, fully browser w/ the fully DTH and webcore is a better option. Either way what you are wanting to do is completely possible.


I am actually using Fully to display a home assistant dashboard but I am unable to configure it in such a way that the screen stays off until I need it. Tried motion detection but that turns on the tablet when the lights turn on so no good. It is a fire hd8 but it does not have tap to wake (like most Samsungs/Sony tablets) hence my idea with a button to just turn on the screen.
Currently I have it displaying a black screen but I don’t like the tablet being on all the time

Have you tried this?


Not yet, will give it a shot tomorrow. Did I understand this correctly, the fire tablet can be added as a device in ST and then it can potentially send these commands:

  1. screenOn()
  2. screenOff()
  3. setScreenBrightness(0-255)
  4. speak(“text of choice”)

    Which would be great as I could map the ST button to screenOn() and achieve what I was looking for?

Yes, w/ core/webcore

Good progress, I have the Fully Kiosk Remote integration working (it is showing up as a device in ST) and it can do screen on/off and all the things from above which is awesome.

WebCore also installed but having issue with my piston, it is not triggering the screen on of the tablet, is my syntax wrong?


Just to report back the above actually works just fine with the physical button, I was trying it out with the Test button from the webcore dashboard which doesn’t seem to work.
Thanks @sidjohn1 for your help/suggestions

1 Like