SmartThings Button Sporadically Stops Working


(Timothy Ardoin) #1

Hi all, pretty new user here.

I have a hub v2, a SmartSense Button, a SmartPower Outlet and that’s it. Yes, only 3 things with one function, to control a set of lights. These are all “SmartThings” branded items, advertised on their main page.

The hub is 8 feet from the button and outlet and there is no wifi router near it.

It seems like once a day or once every other day the button just gets lost. It shows offline in the device list and pushing it doesn’t toggle the power state of the outlet. I have to take the battery out of it and replace it, then it’s ok until I start to trust it again and turn my back on it and it mysteriously disappears later.

This would seem the most fundamental of use cases and among the simplest and most expected to work setup possible. I’m really not getting a feeling of reliability here, and to me, reliability far outweighs cool factor or basically any other bell or whistle you could bring up.

Is this normal? Do you guys just deal with this all the time or do I maybe just have a bad button?

Thanks in advance for any advice!


(Tony Fleisher) #2

There have been several reports on here about similar behavior with the new smartthings button. I would suggest you contact smartthings support.
https://support.smartthings.com/


(Timothy Ardoin) #3

I emailed support but no reply :confused:

Now though I have a bit more info. What’s happening is there is some HUGE lag somewhere. When I push the button, I see this in the online log instantly:

2018-12-08 2:15:43.904 AM UTC
moments ago
DEVICE button pushed Button was pushed true

Yet, nothing happens until FIVE MINUTES LATER! Then the lights turn on (or off). Yes you read that right, 5 entire minutes go by. Five agonizing minutes. Five painfully frustrating, teeth-gnashing, curse-filled minutes (during which the button sometimes gets pushed many more times, queuing up new events that spawn their own additional 5 minutes of lag)

My network is stellar, my setup is painfully simple, and what I’m trying to do is pretty much the opposite of rocket science (turn on a light). My hub is 8 feet from both the outlet and the button, without any interfering devices nearby. The light is green. If one case should work, this should be it, and yet, it’s an embarrassing disaster. I’ve spent literally hours trying to get Smartthings to reliably control one light.

“The boss” has registered her displeasure with this whole setup. Anyone have… anything at all, before I chuck this hub in the garbage and try to set up an openHAB system instead?


(Steve White) #4

This issue was also prevalent with the Iris buttons, and I also occasionally experience it with the Aeon Labs remotes too. I think there is a fundamental bug in the platforms implementation of the button capability.


(Timothy Ardoin) #5

I might have figured something out. I removed the “new app” and installed the “classic” one. Set up most of the stuff again, including removing the button (which seemed to be stuck on “pressed” state, which was weird) and re-added it. I added a “button controller” app copied straight from templates, and set up the button to use it (I tried this before removing/re-adding the button, but the original functionality for the lights was “stuck” to the button with no way to remove it). My thought was have this smartApp routine do the logic, and bypass whatever bad thing is happening in the built-in routine.

So anyway now it works great.

Will it continue to? Time will tell, but the old app has a lot of functionality that the new one is simply missing. And most of the docs I ran into online here reference the old app (and it’s very confusing if you’re new to this and don’t know there are two apps!)