Smartthings button lag on the first press after inactivity

I’ve had a ST button very far from my hub. It’s always had 3-5 second lag. I know it’s the distance as if I move the button directly next to the hub it becomes instant.

Today I got a handful of plugs to act as repeaters. The button still had extreme lag. So I learned about healing the mesh. The majority of my devices are z wave and only this one zigbee had problems, so I held the reset button and repaired it with my hub.

Now, after 15 or so minutes of inactivity, the button has about a 3 second lag. But all follow up presses are instant. No lag at all. If I leave it be for 15-20 minutes and go back, again, that first press will have a 3 second or so lag.

Does resetting a device not make it assign a new parent node? Do I really need to heal the entire mesh for this one button? Or is there a way to keep the button from what seems like entering some sleep mode? If I need to ping it with webcore or something that’s fine. I’m just at the point I’m going to by a freaking $50 aeotec button to replace this official branded ST one and that sucks.

Edit - seems the culprit is the sengled bulb and not the button. Even after resetting it and toggling it via the ST app rather than my button, it’s still very slow to wake up on that initial signal.

What’s the brand and model of the plugs that you got? Z wave repeats only for Z wave, and zigbee repeats only for zigbee, so the button needs some nearby mains powered zigbee devices.

As a wise ol soul often says…”What are the model numbers?” Of the outlets and the remotes.
If everything is zwave… have you run a zwave repair?
If everything is zigbee… Power off the hub for 15min to force zigbee to rebuild the mesh.

1 Like

Also, you may have already read this, but if not, try the wireless range and repeaters FAQ. Start with post 11 in that thread, then go back up to the top and read the whole thread.

Tradfri, ZIGBEE, plug. An actual smartthings button. Like branded.

Again. Button works instantly if 2ft from hub. Now it works instantly but only after the first very, very laggy press. The next 15 are all instant.

Does resetting a device heal ITS routing or would I need to heal the entire mesh? And if it is the routing, why are all subsequent presses instant?

If you remove a device from the network and then join it to the network again it will get a new parent and be up-to-date on the available repeaters. So that part is fine Since you are dealing with the battery operated device, that is a child.

If you add a new potential parent to the network, like the plug-in pocket socket, then that doesn’t change the stored information in all of the other devices, which is why you heal the whole network to get a new repeater to be used accurately by the other devices.

as far as what you’re seeing, doesn’t sound like a mesh issue to me. It sounds like a latency issue with a battery operated device which falls asleep if it hasn’t been used for a while. But that’s always very specific to the individual model. Some manufactures are aiming for longer battery life, so they have their devices sleep more. Some devices have parameters that let you adjust their sleep periods. It just varies a lot.

At this point, I hope someone who has that particular device and has experience with it will be able to chime in here.

The only thing that confuses me is you’re saying that if the button is physically close to the hub you are not seeing this latency. You’re not seeing it ever? That is if you put the button on a table near The hub and you just leave it there without touching it for 24 hours then the first time you touch it there will not be a three second lag before the target event occurs? But if you left the button someplace else in the house without touching it for 24 hours, then the first time you pressed it there would be a three second lag?

Because if that’s true, then that does sound like routing, so I’m confused.

Thanks for the info. The problem is old testing with old variables and not at all being methodical.

The moving the button was weeks ago. I think adding the repeaters did help some, but I slowly moved closer to the hub as I tested. Which means that initial delay lag was also gone as I moved. I also held it right under a smartthings plug thinking it would go through it and thought I noticed improvement, which understanding the mesh now I know was subjective AF.

I am hesitant to do a full mesh heal as the other zigbee devices are running perfectly. The smartthings button is turning on a sengled bulb. If I open the app on my phone and toggle the light that initial switch has very similar lag. So I don’t believe the button is the culprit and instead it’s the light.

I also reset the bulb so it would pick a new parent. No impact. I’ve set webcore to refresh the bulb every 15 minutes. No impact. At this point I think the sengled bulbs just take a second or two to kick on. And I’ve given up. I was going to set my wife’s nightstand up to be identical but a 2 second delay is NOT wife approved.

I know mesh isn’t the problem. I know the button isn’t the problem. And I don’t care enough to replace the bulb or carry a lamp around the house. So it is what it is.

1 Like

I’d like to bring this topic back to life, as I’m having the same issue.

I’ve invested in a variety of buttons: Samsung Button, Aoetec Wallmote, Aeotec Nanomote, Ikea 5-way button. ALL of them give no response after being inactive for a while. I’ve moved the Smartthings Hub to the same room as the buttons/switches and the result is the same.

After pressing it a second time, the buttons will function normally, with expected lag. Are there more people still experiencing this? Because I’ve compared different buttons, I feel like maybe it’s my Smartthings V2 Hub. Are people experiencing this with their V3 hubs?

This question comes up about once a month, you can find lots of forum threads about it. It’s probably not the hub, it’s just the way those protocols work. In order to save battery life, most of these buttons regardless of brand will “go to sleep” during periods of inactivity in order to save battery life. So it can take an extra press to wake them up if they haven’t been pressed for a while.

You can’t do anything with polling or anything like that: it’s just the way they work.

There are three alternatives, but all involve not using that kind of device.

  1. You can get a “battery free” device like the zigbee green power devices. They don’t have to save battery life because they don’t have batteries, they work just from the kinetic energy of the press. Probably the best known of these is the Phillips hue tap, but there are others. But then there’s the issue of how and if you can get them to work with smart things, which is a whole separate question.
  1. You can get a different kind of remote using a different kind of battery, but it’s probably going to cost a lot more. One obvious example is the Logitec Harmony companion to their Harmony Hub.

Lutron pico remotes also don’t sleep in this way, they are using their own proprietary protocol, but there’s no easy integration with smartthings for those.

  1. Or you can get a mains powered switch.

But many inexpensive battery operated buttons get their battery life by sleeping a lot. The only workaround for that is to make sure they get pressed every 12 hours or so.

There have been many discussions on this in the past in the forum. But it’s definitely not anything to do with the hub.

Thanks. I try to research before asking questions, which is how I came across this old thread. Ah, that’s disappointing. It was almost perfect too, but too inconvenient to stand there and wait for the confirmation of lights to turn on for it to be practical. We’re not there yet.

I actually already have a Harmony remote/hub but that’s not something I want to stick to my wall to blend in as a light switch.

I may just have to go through the trouble of hard wiring a receptacle the ol’ fashion way.

1 Like