SmartThings app tv remote operation

Hello, I am new here so I hope I am posting in the right place. I have a Samsung Series 7 tv and a Series 8 tv that I recently linked to Alexa via the SamrtThings app. The series 7 worked perfectly and both the SmarThings app and the Alexa app are able to fully control the tv.

The series 8 tv didn’t do as well. At first both SmartThings and Alexa were only able to turn it on. Then I realized that the series 8 has a setting for remote operation that must be toggled in order to turn the tv on with SmartThings and Alexa.

Now the issue is that neither of the apps can change the channels on the series 8. I noticed that several of the SmartThings app remote functions work, but not the channels. Does anyone know if there is a setting that will fix this? Thanks!

Hopefully someone here will have a suggestion.

Meanwhile, this forum was set up a number of years ago so that customers could help other customers with the home automation platform.

There is an official Samsung support forum with Samsung employees assigned to help there, and they do provide support for the smart televisions. So you might get a faster answer if you try there.

Thank you. I posted there as well but no replies so far after 24 hours. I am certain that the issue has to do with the SmartThings app or a setting in the series 8 television since Alexa simply tells SmartThings what to do.

As I mentioned, so far I have been able to get the apps to turn the TV on and off, as well as manage some other functions like changing the source input, but they won’t change the channels on this tv. I consider myself pretty knowledgeable when it comes to these things, but they really don’t have to make it this difficult to figure out.

1 Like

IDK if this link would help but someone had a similar problem like yours.

Unfortunately, Samsung support has not been very helpful. First they told me in order to activate the channel changing feature of the SmartThings app so it will work with the 8 series tv I should delete and reinstall the app, and then delete and reregister the tv on app. I did that and it worked, it actually changed the channels for like five minutes and Alexa was able to control the feature. Then it stopped working, and went back to only turning the television off. Not even turn on control works anymore.

I advised them about this and the response I received is, “I would like to inform you that there is no option for Chanel changing”. Huh?

SmartThings seems to be one super glitchy app, and the support crew seems to be throwing stuff at the wall to see if something will stick.