SmartThings Community

Smartthings app on Samsung Galaxy S9 no longer updating location after Android P Update

Prior to the Android Pie (9.0) update to my Galaxy S9, the Smartthings app location/presence sensor was working great.

But now, after the P update, the Smartthings app on my phone no longer updates at all. Life360 is updating location well.

I have tried all the things listed on many of the posts such as, turning off battery saver, allowing all background data refresh, make sure the Smartthings app has permission to access location on the phone, turning off Adaptive Battery, removing and adding back the phone sensor in the Smartthings Classic app, turning off and back on the “use phone location” setting in the Smartthings app, etc.

In the non-classic Smartthings app, when I click on my phone sensor icon, it says, " Can’t connect to device. Check device and try again."

In the Smartthings Classic app, when I check the “Recently” tab for the phone sensor, the page has no activity even though I have left home and returned several times according to Life360.

Any ideas why the phone location/presence is not working in the Smartthings app?

Thanks in advance for your help.

See my post, maybe someone has the answer through trial and error.

This won’t help too much, but I don’t think it’s Pie in general. I upgrade to Pie several weeks ago and haven’t had an issue with presence, other than the delays in reporting arrival that I’ve experienced all along.

Not sure how much this will help either but I wonder if it’s something specific to Samsung and it’s handling of background services. My girlfriend has a galaxy s8 not currently on pie and her location does not update correctly even after taking the same troubleshooting steps you described. I’m on pie with a pixel 3 and rarely have issues with my presence not updating.

Thanks for all the replies.
The main reason I suspected Android Pie is that prior to the Pie update, everything was working great, including the Smartthings app.

But I removed the App Presence device from my Smartthings Classic app and then re-added it. I had to update all my Webcore Pistons to use the re-added device.
That didn’t seem to work, but once I rebooted the phone, it started working.
It’s still slow to update sometimes, but at least it’s changing status. Before it would never change to away.

Unfortunately, for any presence sensor to work, I have to disable all the battery saving background data settings. My battery now drains much faster. If I enable battery saving, but set all the presence apps to never sleep, don’t manage power usage, always allow background data, they still won’t update fast enough.

Oh well, I guess there’s nothing I can do.

I wonder how Waze (navigation app) does it. No matter what settings and power saving settings I have turned on, Waze always updates my location in real-time. Other apps like Runtastic for tracking my exercise/walking will not work if Battery Saver is enabled.

Thanks again for everyone’s help.