SmartThings app not showing member

I have some Samsung SmartTags managed in the SmartThings app, of course. My husband has been a member of “My home” for some time. He’s now using another phone and, while on his phone he’s able to see and track the SmartTags, his device doesn’t show up on my phone under “member’s devices” despite okaying location tracking. When I click “member’s devices” I get the “invite member” page and link, even though when I go to “manage my home” he’s listed there? I’ve tried using the "invite member via QR code with him twice but he still doesn’t show up. Apps on both phone are updated. Any ideas? Thanks in advance!

1 Like

Just curious…not sure what you’ve tried…have you gone into ST’s settings and tapped “Get your location from this phone”?

Can he see his own phone in SmartThings Find? Only one possibility is that he doesn’t have Find My Mobile enabled on his phone.

Oooh, thank you! It’s a new phone so very possible that step was missed. We’ll check that!, thank you

I think that may be it. It’s a new phone, so very possible it was a step that was missed. We’ll check it out, thank you!!

Do you mean “share this device’s location”? If so, yes. But others are suggesting we may have missed enabling “find my phone” and that may be the issue. Gonna check that out and see if that’s the issue. Thanks for your help!

This is so frustrating. “Find my mobile” is enabled and in Location Permissions, Smart Things is set to “allow all the time”. Still, no dice. I’ll admit that we’re new to SmartThings/Smart Tags and the app settings don’t feel intuitive, but when I initially set it up a few months ago on our older phones, it was a snap; no difficulty whatsoever. We’re using newer phones now. I’m the “owner” of the smart tags and having them show up on the new phone wasn’t an issue; I added some new tags without issue as well. Everything works fine except my husband’s phone doesn’t appear on my end? I’ve removed my old phone from SmartThings entirely during the process of trying to troubleshoot the current issue just to make sure it wasn’t part of the problem and my husband deleted the SmartThings app from his old phone as well. When I go to “find” on my phone and click on “member’s devices” it takes me to the “invite a member” screen, even though when I go to 'manage my home" it shows 2 members - the two of us. I’ve deleted him as a member then re-added, we’ve both restarted our phones a few times now. He can see my phone but his doesn’t appear, nor does “find” seem to think he’s a member? I’ve tried double adding him (going through with the “invite a member” page I arrive at when clicking “Member’s devices” even though he already shows as a member in “Manage My Home”. He invited me to his “my home”, but it gets us nowhere as he has no tags and there is no “find my phone” option there. What am I missing? Is it some odd phone setting? He’s using a Samsung Galaxy S21 5G. I’m using a S20 FE 5G. Happy to share screenshots if that’ll help at all.

Let’s focus purely on your husband’s phone for the moment.

In the SmartThings app with the Favourites page open the current ‘Location’ should be listed at the top. Clicking on that or the house icon next to its should show two Locations. One should just have the Location name (‘My home’?). That is a default Location that gets set up for each user and we aren’t interested in that. The other will indicate that it is owned by you and that is the one you invited him to be a member of. The latter one is the one we are interested in so we need that to be the one that is selected.

On the Devices page, if all is well there should be an ‘On the go’ room that lists the SmartTags (unless you renamed the room or moved the devices).

In the Life page there should be SmartThings Find. In that with Members’ devices selected he should see your phone and the SmartTags. With My devices selected he should see his own phone. If he looks at the details for his own phone the Share this device’s location should be selected.

Does that all match up?

I just ran into this yesterday too. The fix was stupid easy. I had to log out of smartthings on my phone (the one that was only seeing one phone), and then log back in. Once I did that I was able to see both phones.

That did it, thank you. Everything was as you described except that last item - under his device his “share” wasn’t enabled. I guess we’d made certain to enable “sharing” on every other device but that. Thank you so much - such an easy fix but a “tear your hair out” kind of find. I appreciate your help!