Smartthings App 'More' Button Crash


Just bought a start pack and having trouble with the app. I am running ios 11.2 on an iphone X and when I log in to the Smartthings app and click the More button on the bottom tab it just causes the app to crash. It was working when I first set up, so I’m not sure what has happened?

I have tried deleting and re-adding the app to no avail.

1 Like

Same here. Although it just started happening for me as of about 15 minutes ago.

Glad I’m not the only one! I’m at the point where I was going to erase iPhone and restore but the only reason I need to get into the More section is more mobile presence and location but I see it isn’t working anyway!

I emailed support, so we’ll see what happens I suppose.

man, i thought i was going crazy for the past week. I didn’t see anyone else having the issue. I thought it was the mobile presence beta i’m in. I did email support, and you should too. they are aware of it, but the more people that complain the faster it will get fixed (typically).

1 Like

So, I’ve had the same issue for a few days. But, managed to fix it just now! I signed up for and logged into the SmartThings website and under Locations discovered that there was some how two “Home” locations. One had my hub and all my devices connected to it and the other had none. I deleted the one with none and the More tab started working immediately!

Hopefully helpful for someone else.


It may help some, but all of the people who participated in the Account Migration Beta, ALL people had a second location created called Home or Home 2 if their original location was titled Home. For these people, they will be unable to delete that 2nd Location created. If they had any Samsung appliances, those devices were moved into that new Location. This is just an FYI for those who attempt to delete the way WorldRover was (did you create a 2nd location at some point, maybe accidentally?) able to.

I have just tried what was suggested and I only have 1 location when I log in. Tried renaming it to Home 2 but still no success unfortunately.

A few of us in the beta have 3 locations. Super fun… :-/

I’ve tried to delete my two “phantom” locations with no success. I always get a 500 error when doing so.

I have a suspicion this is more of an iOS bug than a ST backend bug as I can access ST on my Android devices.

1 Like

i was actually able to FINALLY delete my second location created by the migration beta. Not sure what I did different, but it finally let me without the 500 error.

1 Like

Are any of you in the mobile presence beta?

I believe that ST removed this restriction. I left my phantom Home Location alone for the last couple of weeks after failing to be able to delete it shortly after the account migration beta. Just went into IDE and deleted without issue.

I am Android as well (no iOS) and I ended up with phantom home as well without ability to delete it. That is until 30 seconds ago. See post above.

1 Like

Hehe, there was nothing for you to try. You have a single location and nobody suggested you rename to Home 2. I stated in my post that people who were part of the beta ended up with a second location called Home, and if their original location was Home, then the second location got created as Home 2. :slight_smile:

Or fixed the bug :laughing:

1 Like

Son of a … LOL Yup. Deleted my other two locations and I can get into my iOS app now.

I love betas… but I hate betas… :wink:

Thanks for the tip!

1 Like

For every bad day or two, a good day follows

1 Like

well you guys suck haha. Deleted mine a week or so ago and its still not working.

Hehe, I only wanted my extra location deleted because it was annoying. If I force stop the app, that default location would always be selected first in the mobile app making it appear like I had nothing in ST. I am not having the “More…” issue as I am on Android :slight_smile: