Smartthings + Alexa Integration - Simulated Switch HELP!

Hi, All.

First of all, Please no hate or redirect requests to other forum posts - I have majorly and extensively searched for support all over the web for the past 4 days and have not managed to resolve the following issues.

I will try to explain as plainly as I can, but first, a little bit of background and where the issues have arisen.

I have been a smartthings user for about 4 years now. I have had the V3 hub since launch, and on Saturday evening (25th April 2020), randomly and out of nowhere, my app notified me that my ST hub was offline. A long story short, after much faffing and researching/troubleshooting, I couldn’t get the device to come back online (Yes, I did power cycles, reboots, resets of the app, device, hub, router etc) nothing worked to resolve it, so in the end, on Monday 27th April 2020, I decided to give in and purchase a new V3 ST hub. It came yesterday (Tuesday 28th April 2020).

So when I received the new hub, I thought, all I need to do, is start from scratch. So, I logged into the IDE and had a lot of trouble trying to delete the existing devices/smartapps etc from the malfunctioned hub. I finally managed to delete everything from the location except the location itself. Still to this minute I am not able to delete the location, I have changed it to ‘false’ under default location but it still will not allow deletion. Anyway…

Now I have the new hub and under new hub and new location, set as new default, I have added back all my Hue lights, ST motion sensors and multi purpose sensors.
However, on my old set-up I was using bjpierron’s ‘Simulated Alexa Switch’ with all my RF/IR devices in the home.

I have 3 Boradlink RM’s, an android tablet using RM Plugin and acting as the bridge, and also Amazon Alexa.

During my original set up of this, I referred to the guide here:

I had everything set up perfectly and it was all working up until Saturday night as mentioned above, but because I couldn’t resolve the existing issues, I decided to get a new ST hub and start again.

Now, the problem is, for the absolute life of me, I cannot get this to now work with the new set-up. I have mirrored exactly the same as I had set up before, but I can only get as far as the routine in Alexa App.

No matter what I try, I cannot get Smartthings to trigger the Alexa routine. Exactly the same as before, I added the DTH for Simulated Switch -

Then I created a new device, assigned to my new hub and new location, marked as Self-Published. The device immediately showed up in the ST app, and I had to discover devices in Alexa to add the device there.

As before, I created the Alexa routine - example - If ‘Cinema Projector Screen Switch’ Contact Sensor ‘Opens’ , then, ‘Control’ ‘Projector Screen Down’
Cinema Projector Screen Switch is the Alexa Simulated Swith device created in IDE
Projector Screen Down is the Button from my Projector screen’s RF remote set up in Broadlink app and added to Alexa Device list .

There’s no problem adding the devices or the routines in Alexa - And after I create the routine, I can press the play routine button and its working.

Now referring to the guide I originally followed, The next step is to create the automations in ST app. I did the automations and followed exatly as I did before, but I cannot, for love nor money, get smartthings to trigger the Alexa Routine.

On my original set up, I had all this working absolutely perfectly with no issues until my hub decided to stop working. I also use ActionTiles which has now messed up too and need to start that from scratch too but I find doing that pointless unless I can resolve these issues.

It is beyond frustrating, as I know that it SHOULD work because it always had done before,

I don’t know whether something has now suddenly changed thats preventing me from doing what i did before, or whether I have miraculously become stupid and not doing something I should?

In the RM plugin app, everything is the same, the tablet is still acting like the bridge and I am still able to discover existing and new devices in Alexa.

I am adamantly sure that Smartthings is definitely the issue here. Before, I remember, when creating the autmations, that on the ‘Then’ command, it gave a few different choices below, On or off of a device, like ‘Custom IR button’ - but none of this shows up anymore.

I spent a lot of time, effort, and money setting all of this up originally and now I am getting pretty close to ripping it all away and throwing it completely.

I have managed to speak with samsung who have been informative, but at the same time, useless. Because the Simulated Alexa Switch is a custom non official DTH, they wont offer any help.

I don’t want to sound desperate (although, I am at this point) but if anyone could pretty please help me out to get this or something similar working again, I will happy buy you a couple beers, I am happy to contribute to anyone that can help me get this back working

I have read all over the net over the past couple of days that this custom DTH is a bit hit and miss for people, whether it either works or doesn’t - it’s very annoying for me because it always worked before and now suddenly it does not.

I haven’t been able to find any kind of alternative to using the Simulated Alexa Switch, but if there is one, as long as it won’t rack my brain too much, I am willing to try anything at this point - I have read a few things about WebCore, but I am not very confident with the set up of this or whether it would even work with RF/IR devices - I tried to look at WebCore before but it was too confusing for me and I don’t want to make anything break.

I do consider myself somewhat technically minded, so if there is an alternative method, please please can you share with me and help me out?

I have so many devices I had successfully working via the Simulated Alexa switches previously, and all I want to be able to do is set these back up to work in smarthings.

I have pretty literally pulled my hair out over this - i know it sounds ridiculous, but I have gone so far beyond frustrated with the lack of detail/support/resources online and beyond annoyed that it’s all of a sudden not working now.

I have the V3 ST hub, 3 x Amazon Echo Dots (1 is 1t gen, other 2 are the new gen), Philips Hue bridge, IFTTT app, 3 x RM Pro+ IR/RF Wi-Fi remotes with the broadlink/e-control/ihc apps.
For Samsung I have the Connect and Classic app as well as familiar with the IDE web platform.

I would appreciate some real support here please, I don’t want to sound ungrateful, but if you’re here only to respond with links to other forums, trust me, I have probably already seen it and not been successful - I have been in this very annoying situation since the weekend and have checked 1000s of different topics and threads including the comments. I have also watched hours and hours of youtube videos/tutorials, still without any success of getting any further

To summarise - I have got as far as successfully operating the devices through Alexa routines - the problem is purely with smartthings - I can create the device and the automations, but theres somethinf not quite right with smartthings and it’s not managing to talk to alexa to trigger the routine I have set up.

Any support, would be very much appreciated.

Thank you in advance

Well first on tis one - did you try to delete the old location from within NewApp? (I had the same thing happen where when I added my wife’s account she had a dupe Home location I couldn’t delete in teh IDE even after the ‘false’ flag trick - apparently the dev team implemented a change in NewApp that handles this situation and makes it able to be deleted there even when the IDE or Classic fails.

Ok on to the other part - if you tore down and restarted, did you tear down your Alexa integration and
use the new updated Alexa Skill (new as of like a week or so now) or the old one? I think they’re handling things differently…

1 Like

thank you for your reply, i appreciate it

i did try deleting in the app also, yes. i tried to delete in the ST connect and the ST classic app, and also the IDE; none of them worked. i eventually managed to delete all the devices and the hub, smart apps etc but the actual location itself just returns an error message ‘cannot be deleted’ even though there is now nothing at all attached to it.

in relation to tearing down and restarting - yes - i disabled all the skills in alexa, deleted all devices and routines, signed out of the app and then signed back in, then reactivated and relinked my skills/accounts

Which skill are you referring to? for smartthings there is only 1 skill i can see which is enabled and linked - and I have also tried disabling and relinkng, logging out and back in a number of times, reauthorizing etc without success

As for the other skills relating to broadlink - the ‘ihc’ has now disappeared from the skills store and i can only see ‘ihc for eu’ which is what i was using before and was working fine - the same as smartthings skill, I did disable, log out, log back in, re-enable and relink - again, without success…

I know you don’t want links to any other threads in the forum, so I am not going to participate in this thread after this particular comment, but, as @nathancu just told you, smartthings released a new version of their Alexa skill last week without telling anyone and if you disable the old skill, it will disappear and you will not be able to get back to it again. You will have to use the new skill, which is not working perfectly. It has the same name as the old skill, but it is different. :disappointed_relieved:

There are threads about this in the forum, so you can find those for yourself if you are interested in knowing more. There’s a staff member collecting bug reports on the new skill in one of those other threads, so it might be worth a search if you have the time.

1 Like

Thanks for your reply, JDRoberts - I didn’t mean for my post to come across negative in any way by asking for no links to other posts - I felt I needed to add this in because I have spent so many hours searching all over the net for solutions - I am not one to really post on forums unless I really have to - Most modification/customisation when it comes to smart home and automation I can usually do by myself through following guides and tutorials - Apologies if it did come across the wrong way but I didn’t want to be wasting more time looking at posts I’ve already seen.

I am aware that the skill is relatively new and updated, but I assume like so many others that Samsung should’ve or could’ve carried over the same code from the old skill, preventing all the issues.

Anyhow, my stress levels are I am glad to say, now reduced as I have found and am implmenting a similar alternative.

It still requires me to have an android device with RM Plugin app (which i was running before anyway) but eliminates the need for Alexa - Instead of using the ‘Alexa Bridge’ - Instead, I have received some direction and support by means of using the RM plugin app’s ‘HTTP Bridge’ instead.

JUst like with the Alexa Bridge option, it still requires a bit of faffing, but I have managed to get it working using the HTTP bridge opposed to Alexa Bridge.

The guide I followed, for others that are having the same frustrating issues, is here :

I found this very easy to follow and all it needs is the IP address of the HTTP Bridge/Android Device, along with the Port, MAC address of the RM Pro Device, and the Code ID. Once all of this is entered into the newly created ‘Broadlink Virtual Switch’ on the smartthings IDE, and preferences have been updated with the command, the switch inside the smartthings app works straight away.
Alongisde this, I have also used IFTTT for single button commands to turn the virtual switch back off after being switched on.

As this new way is now working for me I am happy for a moderator to close this thread, unless it needs to stay open for others that are experiencing the same issues?

Thanks for those who have responded

1 Like