Smarthings devices going Offline in Google home every 24 hours

My Google Home integration of Smartthings has worked for years. Recently I reconnected my account because devices seemed to stop syncing and now ALL the Smartthings devices go Offline in the Google home app (still active and working in Smarthings) every 24 hours or so. Doing a “Reconnect” of Smartthings within Google Home app reconnects everything but I’m not going to relegate myself to relogin every 24 hours.

Any ideas for how to fix this so Smarthings stays linked in Google Home for longer than 24 hours?


Welcome to the community.

I do not think this will solve your issue:

But it may offer you some clues?

1 Like

Thanks some interesting insights, thanks for sharing. Unfortunately, I didn’t pick up anything that would help my issue here. There is nothing of-interest in the activity feed that would indicate a disconnect.

Same thing happened to me last week. I reconnected my account trying to fix an issue with one device and now all devices drop offline in Google Home every day or so until I do a reconnect. I tried completely unlinking and then reconnecting. No luck.

I’ve tried many things like deleting the apps and reinstalling, clearing cache, unlinking each direction (e.g. from ST or Google home). Still is an issue.

One thing I noticed is if I make a NEW Smarthings account and added a few virtual devices to it, that new account stays connected just fine. There is something up with the original Smartthings account and Google home interaction.

Another data point

I unlinked from both ends and was going to wait several days before reconnecting just to see if something would get reset on the server side. During that period I ended up getting a new phone. So about 1 week after unlinking on the old phone I reconnected using the new phone.

At first I was a little optimistic because the ST devices all showed up in GH as “linked to you” whereas on previous attempts they were still assigned to rooms.

But sure enough after a day or so they all went offline.

I might try connecting to a new Google account next.

Thanks for the feedback. I submitted a ticket to Smartthings and they believe its an issue on the Google Home side so I will be submitting a ticket to google now.

I submitted a ticket to Google and they think its a Smartthings issue :point_right: :point_left:

:roll_eyes:

Thanks, I haven’t yet brought myself to try a different Google account…worried it’ll somehow corrupt things even more

I submitted feedback to Google through the app last week but haven’t heard anything

Any luck with anything? I’m dragging my feet to redo my smart things, hoping this either fixes itself or someone figures out the root cause here (I submitted tickets to both Google and Smarthings and both companies are pointing the finger at each other).

Can you still control these ‘offline’ devices via Google Assistant?

I don’t have a follow up suggestion based on the answer. My thinking is simply that SmartThings connects to Google Assistant so it would be good to know how things are with Google Home taken out of the loop.

@heavyd1850
I disconnected ST from one Google account and reconnected to another Google account. A day later the devices were all offline. Don’t know what to try next.

@orangebucket
No, Google Assistant says it can’t reach the devices once they go offline in Google Home

I made a new Smartthings account and added virtual switches and that account stays connected. I’m under the belief if I move my hub to the new account then all the devices will stay connected. Issue is there isn’t an easy way to do this, I would need to remove all the devices and the hub from my current smartthings account then connect them all back up to my new account.

I read about some Google Home updates last week so on a whim I tried reconnecting my original account (had already switched back to it after my previous experiment of connecting to a different Google account).

Well, I’m probably going to jinx it but it’s been 5 days and the devices are still online in Google Home. So hopefully it’ll stay that way and maybe it’ll work for you @heavyd1850

I’m seeing the same actually!

Where did you read about the updates?

It was this blog post I ran across. Makes no mention of ST but I thought maybe some bug fixes were included in the update. Who knows if it’s related. Glad to hear it’s working for you.

1 Like