SmartApps for automation are no longer available

@nayelyz Is there anything to report? (Sorry to chase, I’d just like to know if Smartapps are going to survive -:slight_smile: )

@nayelyz Hi there! I also wonder if Smartthings automation would work in the future. Is this possible to create a new automation project through your API (even if you removed it from UI)?
See docs.

I did try this and got ‘quite’ far…I managed to create an app and confirmed the url hosting (with the register), it now shows as app when I use the api to get apps. However, I can’t find a way to install it -:slight_smile:

@orangebucket I think tried this as well and could probably be clearer on what happens

2 Likes

Aha Sorry I see he did indeed follow the same process (and as I thought described more articulately)

@nayelyz @SupportTech Any updates?

1 Like

Tagging this again. The SmartApp shell that would allow webhooks and/or Lamba is no longer available.

@nayelyz @SupportTech

(and you cannot API develop one, since there is no ‘publish’ function in the API)

For example you can’t do this anymore:

2 Likes

I did the same, you can get all the way with the API building up the SmartApp, you just can’t publish it to the mobile device to install it.

4 Likes

I found some info about installation flow here.

App installation involves an OAuth process that allows a user to accept any requested permissions. After authorization, an Installed App is created.

So I tried to follow this instruction. I managed to register an Automation App and see it under the ‘/apps’ endpoint.
The CLIENT_ID and CLIENT_SECRET were created successfully. When I go to the ‘Website URL’ from the server log, I’m able to log in with my SmartThings account credentials.
On this step the URL in my web browser looks like this:

https://api.smartthings.com/oauth/authorize?client_id=my_client_id&response_type=code&redirect_uri=https%3A%2F%2Fmy_app.eu.ngrok.io%2Foauth%2Fcallback&code_challenge_method=S256

BUT!!! When I click the ‘Authorize’ button I get a 500 error from SmartThings.


Error:
GET /oauth/callback?error=invalid_request&error_description=The+request+is+malformed. 500

What should I get according to docs:

https://my_app.eu.ngrok.io/oauth/callback?code=blablabla&state=blablabla

In conclusion, I cannot install my app, because I cannot authorize it. The authorization code cannot be generated through endpoint https://api.smartthings.com/v1/oauth/authorize.

1 Like

@nayelyz any news for us?

2 Likes

@andresg Hi, Andres! Does your comment apply to my OAuth authorization issue as well?

Tagging @jody.albritton as well as @nayelyz since a lot of the demo apps are from his desk.

The silence on this topic is very odd. It should be easy to say: “we made a mistake and they are fixing the dev portal to allow automation apps as documented everywhere” or “sorry, we don’t support automation apps anymore, please go elsewhere”.

Hopefully it is just an oversite on the dev portal updates…but the silence says otherwise…without notice.

6 Likes

This is true. Despite the change in their developer’s platform, we always wanted to stay with SmartThings due we think it has many advantages from other Smart Home systems, but since we are stuck here, and we just don’t know for how long, we have decided to continue going so we already bought other HUBS to start the migration process.
Hope they can give us insights soon enough before we are forced to use other systems.

Howdy! Just putting this on top of the question list again. @nayelyz

Thanks for the help.

3 Likes

Hi, everyone. Sorry for the delay, we were getting more information from the team. This is the feedback so far:

Automation for SmartThings App in the Developer Workspace have been impacted by recent system upgrades. We are addressing this issue and will have further updates as soon as possible

4 Likes

I think it is worth keeping this thread alive and on the ‘radar’. Let me know if I am irritating anyone

4 Likes

Yes indeed, we are blocked from creating new API-only apps.

Currently no way to run many of the SDK samples or handle events from the Subscriptions API until this gets resolved.

I also tried using the submit a request link from the OAuth Integrations page.

This too results in an error 500. :grimacing:

If Samsung needs any help with testing a preview release, you have several hungry developers on this thread who are chomping at the bit to provide feedback. :grin:

2 Likes

@nayelyz I understand you’re not able to say what you’re not able to say, but having Smartapps disabled for a smart home platform is quite a big deal, especially less than a month before a major transition. At the moment people are not aware of solutions that could keep them on SmartThings, that could save them a lot of time and money. Can we have a little more urgency in addressing this issue definitively, because the software engineers have been working on this for 8 days now, and from your last comment, it’s not clear if Smartapps will return at all.

1 Like

Hi, everyone.
Just to let you know that SmartApps are available for creation again in the Developer Workspace:

8 Likes

Fantastic news! Thanks so much @nayelyz!! :smile:

1 Like

Oh Excellent. I was not very hopeful!!!