Can't create “Automation for the SmartThings App”

I cannot create a SmartApp anymore because the project type "Automation for the SmartThings App” is gone.
Before, when I create a project, it looked like below

But now in the developer workspace, there are 4 types of projects below

Can anyone help?
Thanks

I think SmartThings Cloud Connector may be close. And it has two options: SmartThings Schema and SmartApps

I want to create a SmartApps, but I don’t know how to create SmartApps because I tried two times, and they all are “SmartThings Schema Connector”.

I followed the documentation here for SmartApps Get Started with Cloud Connected Devices | SmartThings Developers, but in step 4 my server redirect the link to https://c2c-ap.smartthings.com/oauth/callback?response_type=code&state=eyJhbGciOiJIUzM4NCJ9.MzYwNDEwYmMtOWU2ZC00NmYxLTkzNzctMjQ5MjQ0ODU2ZTlkOnZpcGVyXzVmMTEyNzIwLTY5M2ItMTFlZC1iNTY2LWM5ZDMwMWJhOWU5MDoxNjY5MDExODQzMTE2OjNjZGYwZmQyLTRkMWYtNDMzZi1hMGQ0LTA0YTcxZTQxN2JlMjplbjo.mxwtapxHTwA4M0hdn6JIaAJ3Gb57uC1ultEj59OoAudr9yF8cfSA2aK-tMykIn9D, and in step 5, it always told me “Somethins went wrong… Request Code: 0WIFZF”. Different request code every time, but always wrong.
Can anyone tell me what’s the right redirection and is there any sample code I can follow?

I am really frustrated by this change and have no idea how to create an Automation connector.

Using a SmartApp to integrate a device is a similar process to creating one for an automation, and indeed you can do both with the same SmartApp. However the SmartApp option has disappeared from there as well.

It was first reported on the forum five days ago but no one has admitted to knowing what is going on yet.

3 Likes

Tagging @nayelyz

1 Like

We have the same issue, hope someone can clarify what is going on, if SmartApps are going to disappear, or when are they going to be available again through API Rules or in any other way.
I have seen that Nayely is very good at support, so I will tag her too.
@nayelyz

1 Like