SmartApp which's related to a project in workspace has shown two in Smartthings app

Hi, there :wink:

I’ve been making a SmartApp to monitor my SmartThings devices after creating a project in developer workspace.

Creating a project in developer workspace looks fine, but when I try to install the SmartApp in my phone, I could see two of SmartApp looks a little bit different like below,

As you can see above, Http.Bridge is a project name of developer workspace but the button to install SmartApp was showing as two. The button with description like “Description of Http.Bridge” shows error when pressing the button, “We’re having trouble connecting. Check your network connection and try again”, and the another button without description worked fine when I pressed.

I’d like to know what I was wrong to set up the buttons.
Why is there two button even though I created only a project in developer workspace???

Thanks in advance,

Hi, @Teho_Kang.
This issue is already reported and it only happens on iOS devices. Basically, you see two elements because the version “not deployed to test” of the SmartApp is being displayed as well.
For now, you should use the option that works (the one without description) and install the SmartApp. It should work correctly, so please let me know if you have any issues.

I’ll ping the team to get an update about this. Which version of the SmartThings app are you using?

Oh I see this is already known issue and rerpoted, thanks for recognising me about this, @nayelyz
Yes, I’m using iOS devices and I could see the happening, but I could install SmartApp by selecting the one without description and it worked well as you mentioned. I was just curious why it was happening two menu.

I’m using the version 1.6.83-12.