Developer Workspace - projects are gone?

Has something changed regarding the Developer Workspace? I haven’t gone in there in a couple months, but when I did today, none of my projects are listed on the main page. I was afraid they were gone, but thankfully was able to use the CLI to list and update them.

Hi, @TAustin!

Could you provide more info about this, please?

  1. What kind of projects did you have? Automation (SmartApps) or device integrations (direct-connected, cloud-connected).
  2. Were they created in your private workspace or did you belong to an organization?

I had a small mix of smartapps and a direct-connect device integration.

I know I had an org ID assigned of fE4b, and the device integration may fall under that, but not sure about the smartapps. I had created them under whatever workspace defaulted for my sign-in id.

I’m having trouble even getting to the page. Are you aware of any server issues for it? Could I maybe have an old link? I can’t even find a link to the Developer Workspace from the SmartThings developer pages!

This is your dev’s MNID, all organization’s MNID start with a 0. If you belong to an organization, you see two options in the Dev WS, your “private workspace” and one that shows the org’s MNID. For example:
image

Are you able to see your projects now? It seems the engineering team made a change recently to fix the issue.

About this, I asked and the team mentioned there is a known issue that is present when:

  1. If you are logged into the new console with an account (and have accepted the Terms of Service)
  2. Then you log into the Dev WS with an account that hasn’t, you can get stuck in a redirection loop.

This should be solved by using the incognito mode in the browser. If you see a different behavior, please provide more details so the engineering team can investigate further.

I tried a different browser and it is now working. I can get to the DW and I see my projects now (all under Private Workspace). It may have been a problem with my browser or the redirection loop issue you mentioned.

One piece of feedback: because of the problems I had getting to the DW web page, I had used the CLI to make some updates to a couple of my projects. However now that I can get back in to the web page, the “Last Updated” date it displays for the projects still show the date I probably last used the web page, and not the more recent updates made through the CLI.

2 Likes

Yes, this is somewhat expected because the Developer Workspace has it’s own database and it doesn’t load the changes made in the upstream services.
So, it would be weird only if you had issues with the changes (like the new values don’t get implemented and the old ones are still in use when you call the integration in the app), but they will be out of sync if you make changes from the CLI. You can make the same modification from the Dev WS directly just to visually see the last update.